stubby: add uci support to init file
[feed/packages.git] / net / stubby / Makefile
index 3f3df9c1247c802033a619fc06b435a6ce564d67..cc21d48d17354930b1e89596a72bc5efe54acba2 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=stubby
 PKG_VERSION:=0.2.3
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=COPYING
@@ -29,12 +29,6 @@ define Package/stubby/Default
        URL:=https://dnsprivacy.org/wiki/display/DP/DNS+Privacy+Daemon+-+Stubby
 endef
 
-define Package/stubby/description
-       This package contains the Stubby daemon (which utilizes the getdns library).
-
-       See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
-endef
-
 define Package/stubby
        $(call Package/stubby/Default)
        SECTION:=net
@@ -45,6 +39,16 @@ define Package/stubby
        DEPENDS:= +libyaml +getdns +ca-certificates
 endef
 
+define Package/stubby/description
+       This package contains the Stubby daemon (which utilizes the getdns library).
+
+       See https://github.com/openwrt/packages/blob/master/net/stubby/files/README.md for more details.
+endef
+
+define Package/stubby/conffiles
+/etc/stubby/stubby.yml
+endef
+
 define Package/stubby/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/stubby $(1)/usr/sbin/stubby
@@ -53,11 +57,14 @@ define Package/stubby/install
        $(INSTALL_DIR) $(1)/etc/stubby
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/etc/stubby/stubby.yml $(1)/etc/stubby/stubby.yml.default
        $(INSTALL_DATA) ./files/stubby.yml $(1)/etc/stubby/stubby.yml
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/stubby.conf $(1)/etc/config/stubby
 endef
 
 
 define Package/stubby/conffiles
        /etc/stubby/stubby.yml
+       /etc/config/stubby
 endef
 
 $(eval $(call BuildPackage,stubby))