openldap: fix compilation with GCC14
[feed/packages.git] / net / usbip / Makefile
index 36f29e2f66496d972949f9246314dfe56690dd4b..cf1afa2a2f08a7373b5ddadfd3e44b81a25ba03b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=usbip
-PKG_RELEASE:=14
+PKG_RELEASE:=15
 PKG_LICENSE:=GPL-2.0-only
 
 # Since kernel 2.6.39.1 userspace tools are inside the kernel tree
@@ -52,7 +52,7 @@ endef
 define Package/usbip
   $(call Package/usbip/Default)
   TITLE+= (common)
-  DEPENDS+= +libwrap +kmod-usbip +libudev +USE_GLIBC:libbsd +usbids
+  DEPENDS+= +libwrap +kmod-usbip +libudev +usbids
 endef
 
 define Package/usbip-client
@@ -81,7 +81,6 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-CONFIGURE_VARS+= $(if $(CONFIG_USE_GLIBC),LIBS='-lbsd -lpthread')
 CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
 
 define Package/usbip/install