openldap: fix compilation with GCC14
[feed/packages.git] / net / usbip / Makefile
index 9044344232c2351ce7cb826fc6114eac048b7732..cf1afa2a2f08a7373b5ddadfd3e44b81a25ba03b 100644 (file)
@@ -9,8 +9,8 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=usbip
-PKG_RELEASE:=11
-PKG_LICENSE:=GPL-2.0
+PKG_RELEASE:=15
+PKG_LICENSE:=GPL-2.0-only
 
 # Since kernel 2.6.39.1 userspace tools are inside the kernel tree
 # Package Automatic match version in kernel
@@ -52,7 +52,7 @@ endef
 define Package/usbip
   $(call Package/usbip/Default)
   TITLE+= (common)
-  DEPENDS+= +libwrap +kmod-usbip +libudev +USE_GLIBC:libbsd
+  DEPENDS+= +libwrap +kmod-usbip +libudev +usbids
 endef
 
 define Package/usbip-client
@@ -67,11 +67,13 @@ define Package/usbip-server
   DEPENDS+= usbip +kmod-usbip-server
 endef
 
+define Package/usbip-server/conffiles
+/etc/config/usbipd
+endef
+
 CONFIGURE_PATH:=.
 MAKE_PATH:=.
 LIBTOOL_PATHS:=.
-MAKE_FLAGS+=CFLAGS='-Dudev_device_get_devpath\(x\)=udev_device_get_syspath\(x\)+strlen\(\"/sys\"\) \
-       -DSIGCLD=SIGCHLD'
 CONFIGURE_ARGS+= --disable-silent-rules
 
 define Build/Configure
@@ -79,23 +81,11 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
-CONFIGURE_VARS+= $(if $(CONFIG_USE_GLIBC),LIBS='-lbsd -lpthread')
 CFLAGS+="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include"
 
-USB_IDS_VER:=0.318
-USB_IDS_FILE:=usb.ids.$(USB_IDS_VER)
-define Download/usb.ids
-  FILE:=$(USB_IDS_FILE)
-  URL_FILE:=usb.ids
-  URL:=@GITHUB/vcrhonek/hwdata/v$(USB_IDS_VER)
-  HASH:=84bc5452e4e45c2250e01bc74e03528b2a53c4724b2c4a5feaea76a922f83915
-endef
-
 define Package/usbip/install
        $(INSTALL_DIR) $(1)/usr/lib
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libusbip.so.* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/usr/share/hwdata
-       $(CP) $(DL_DIR)/usb.ids.$(USB_IDS_VER) $(1)/usr/share/hwdata/usb.ids
 endef
 
 define Package/usbip-client/install
@@ -104,11 +94,12 @@ define Package/usbip-client/install
 endef
 
 define Package/usbip-server/install
-       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/init.d $(1)/etc/config
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/usbipd $(1)/usr/sbin/
+       $(INSTALL_BIN) ./files/usbipd.init $(1)/etc/init.d/usbipd
+       $(INSTALL_DATA) ./files/usbipd.conf $(1)/etc/config/usbipd
 endef
 
-$(eval $(call Download,usb.ids))
 $(eval $(call BuildPackage,usbip))
 $(eval $(call BuildPackage,usbip-client))
 $(eval $(call BuildPackage,usbip-server))