bcm27xx-eeprom: Update to the latest master branch(47976e440)
authorRen Zongjia <acooler15@foxmail.com>
Wed, 3 Nov 2021 16:55:55 +0000 (00:55 +0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 12 Nov 2021 19:01:02 +0000 (11:01 -0800)
Signed-off-by: Ren Zongjia <acooler15@foxmail.com>
utils/bcm27xx-eeprom/Makefile
utils/bcm27xx-eeprom/patches/0001-rpi-eeprom-update-OpenWrt-defaults.patch
utils/bcm27xx-eeprom/patches/0002-rpi-eeprom-config-switch-to-Python-3.patch [deleted file]
utils/bcm27xx-eeprom/patches/0003-rpi-eeprom-update-change-default-include-path.patch
utils/bcm27xx-eeprom/patches/0004-rpi-eeprom-update-chmod-silent-f-is-not-supported.patch
utils/bcm27xx-eeprom/patches/0005-rpi-eeprom-config-change-default-text-editor.patch [new file with mode: 0644]

index d67893ac034f538ed8ed34281c70dff6244453cd..4d21769fdad90077e1f44ba6445ef74159d66d92 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bcm27xx-eeprom
-PKG_VERSION:=3129546271da09dde04da5c9715db909b8e1e417
+PKG_VERSION:=47976e4409c6999a8e211976c75c60a97c90275c
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/rpi-eeprom/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=8ae34dd286d777484e670284883c91831ca8bdd15cc90a069009fdf1016de40b
+PKG_HASH:=fe67e174d897c6e29549129522c2fbce2404142e098c3c809c2a3b26b5708055
 
 PKG_LICENSE:=BSD-3-Clause Custom
 PKG_LICENSE_FILES:=LICENSE
index f7b398fc4826a08e85c97563f5d7fe16e9ec9274..b0b5f2e0f95100e6efe1ed1cad96a6758e24deba 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/rpi-eeprom-update
 +++ b/rpi-eeprom-update
-@@ -24,13 +24,13 @@ else
+@@ -24,9 +24,9 @@ else
  fi
  
  # Selects the release sub-directory
@@ -26,14 +26,9 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  ENABLE_VL805_UPDATES=${ENABLE_VL805_UPDATES:-1}
  RECOVERY_BIN=${RECOVERY_BIN:-${FIRMWARE_ROOT}/${FIRMWARE_RELEASE_STATUS}/recovery.bin}
  BOOTFS=${BOOTFS:-/boot}
--VCMAILBOX=${VCMAILBOX:-/opt/vc/bin/vcmailbox}
-+VCMAILBOX=${VCMAILBOX:-/usr/bin/vcmailbox}
- CM4_ENABLE_RPI_EEPROM_UPDATE=${CM4_ENABLE_RPI_EEPROM_UPDATE:-0}
- RPI_EEPROM_UPDATE_CONFIG_TOOL="${RPI_EEPROM_UPDATE_CONFIG_TOOL:-raspi-config}"
 --- a/rpi-eeprom-update-default
 +++ b/rpi-eeprom-update-default
-@@ -1,8 +1,9 @@
+@@ -1,8 +1,8 @@
  
  FIRMWARE_ROOT=/lib/firmware/raspberrypi/bootloader
 -FIRMWARE_RELEASE_STATUS="critical"
@@ -44,4 +39,3 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  BOOTFS=/boot
  USE_FLASHROM=0
  EEPROM_CONFIG_HOOK=
-+VCMAILBOX=/usr/bin/vcmailbo
diff --git a/utils/bcm27xx-eeprom/patches/0002-rpi-eeprom-config-switch-to-Python-3.patch b/utils/bcm27xx-eeprom/patches/0002-rpi-eeprom-config-switch-to-Python-3.patch
deleted file mode 100644 (file)
index 11d3b2f..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-From 869a29ec65a0985670a259f4820df4fafc22c971 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
-Date: Wed, 25 Mar 2020 10:14:34 +0100
-Subject: [PATCH] rpi-eeprom-config: switch to Python 3
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
----
- rpi-eeprom-config | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
---- a/rpi-eeprom-config
-+++ b/rpi-eeprom-config
-@@ -1,4 +1,4 @@
--#!/usr/bin/env python
-+#!/usr/bin/env python3
- """
- rpi-eeprom-config
index 27d5f1e779464b0154fcbd9f1171775ebd82eb5f..51afd53930114db43495a9e9e253b8ec2e254f14 100644 (file)
@@ -24,7 +24,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  fi
  
  LOCAL_MODE=0
-@@ -386,7 +386,7 @@ The system should then boot normally.
+@@ -400,7 +400,7 @@ The system should then boot normally.
  
  If /boot does not correspond to the boot partition and this
  is not a NOOBS system, then the mount point for BOOTFS should be defined
@@ -33,7 +33,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
  
  A backup of the current EEPROM config file is written to ${FIRMWARE_BACKUP_DIR}
  before applying the update.
-@@ -415,7 +415,7 @@ Options:
+@@ -433,7 +433,7 @@ Options:
     -u Install the specified VL805 (USB EEPROM) image file.
  
  Environment:
index bb9fe1408c1c87c1e16344502cc6ce4f46a45f27..0f39bfd791e9678e72961ff7efda8e5964661c7f 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
 
 --- a/rpi-eeprom-update
 +++ b/rpi-eeprom-update
-@@ -212,7 +212,7 @@ applyRecoveryUpdate()
+@@ -223,7 +223,7 @@ applyRecoveryUpdate()
                  || die "Failed to copy ${TMP_EEPROM_IMAGE} to ${BOOTFS}"
  
          # For NFS mounts ensure that the files are readable to the TFTP user
@@ -22,7 +22,7 @@ Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
                  || die "Failed to set permissions on eeprom update files"
     fi
  
-@@ -224,7 +224,7 @@ applyRecoveryUpdate()
+@@ -235,7 +235,7 @@ applyRecoveryUpdate()
                  || die "Failed to copy ${VL805_UPDATE_IMAGE} to ${BOOTFS}/vl805.bin"
  
          # For NFS mounts ensure that the files are readable to the TFTP user
diff --git a/utils/bcm27xx-eeprom/patches/0005-rpi-eeprom-config-change-default-text-editor.patch b/utils/bcm27xx-eeprom/patches/0005-rpi-eeprom-config-change-default-text-editor.patch
new file mode 100644 (file)
index 0000000..66e890a
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/rpi-eeprom-config
++++ b/rpi-eeprom-config
+@@ -129,8 +129,8 @@ def edit_config(eeprom=None):
+     """
+     Implements something like 'git commit' for editing EEPROM configs.
+     """
+-    # Default to nano if $EDITOR is not defined.
+-    editor = 'nano'
++    # Default to vi if $EDITOR is not defined.
++    editor = 'vi'
+     if 'EDITOR' in os.environ:
+         editor = os.environ['EDITOR']
+@@ -317,7 +317,7 @@ Operating modes:
+    To cancel the pending update run 'sudo rpi-eeprom-update -r'
+-   The default text editor is nano and may be overridden by setting the 'EDITOR'
++   The default text editor is vi and may be overridden by setting the 'EDITOR'
+    environment variable and passing '-E' to 'sudo' to preserve the environment.
+ See 'rpi-eeprom-update -h' for more information about the available EEPROM