Merge pull request #234 from HRogge/master
[feed/routing.git] / ahcpd / Makefile
index 38c3dac847c95d6e8ef59131386be45145472f43..043c60997fcb86475c3c9dc567d28fd21f3dbd9b 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -14,6 +14,7 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
 PKG_MD5SUM:=a1a610bf20965aa522cd766bf3d5829a
+PKG_LICENSE:=MIT
 
 
 include $(INCLUDE_DIR)/package.mk
@@ -24,7 +25,7 @@ define Package/ahcpd
   TITLE:=Ad-Hoc Configuration Protocol daemon
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/ahcp/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +ip +librt
+  DEPENDS:=@IPV6 +ip +librt
 endef
 
 define Package/ahcpd/description
@@ -38,6 +39,9 @@ define Package/ahcpd/conffiles
 /etc/config/ahcpd
 endef
 
+MAKE_FLAGS += \
+             EXTRA_DEFINES="$(TARGET_CFLAGS)"
+
 define Package/ahcpd/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_DIR) $(1)/etc/ahcp