luci-app-olsrd2: upgrade uci-defaults for ucitrack handling to use json
[feed/routing.git] / babeld / Makefile
index d419e048da7b54131cd4d8cd3d3f973723330fea..e3d0f5cd74730d21aa3ce6ebb0cf49a5e400e4b1 100644 (file)
@@ -1,24 +1,23 @@
+# SPDX-License-Identifier: GPL-2.0-or-later
 #
-# Copyright (C) 2007-2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
+# Copyright (C) 2007-2021 OpenWrt.org
 #
 
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.9.1
+PKG_VERSION:=1.13.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
-PKG_HASH:=1e1b3c01dd929177bc8d027aff1494da75e1e567e1f60df3bb45a78d5f1ca0b4
+PKG_HASH:=15f24d26da0ccfc073abcdef0309f281e4684f2aa71126f826572c4c845e8dd9
 
 PKG_MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
-       Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
+       Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>, \
+       Nick Hainke <vincent@systemli.org>
 PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
+PKG_LICENSE_FILES:=LICENCE
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -26,19 +25,17 @@ define Package/babeld
   SECTION:=net
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
-  TITLE:=A loop-free distance-vector routing protocol
+  TITLE:=A loop-avoiding distance-vector routing protocol
   URL:=https://www.irif.fr/~jch/software/babel/
-  DEPENDS:=@IPV6
+  DEPENDS:=@IPV6 +libubus +libubox
 endef
 
 define Package/babeld/description
-  Babel is a loop-avoiding distance-vector routing protocol roughly based
-  on DSDV and AODV, but with provisions for link cost estimation and
-  redistribution of routes from other routing protocols.
-  While it is optimised for wireless mesh networks, Babel will also work
-  efficiently on wired networks. It will generate between 1.2 and 2.4 times
-  the amount of routing traffic that RIPng would generate, while
-  never counting to infinity.
+  Babel is a loop-avoiding distance-vector routing protocol for IPv6 and IPv4
+  with fast convergence properties. It is based on the ideas in DSDV, AODV and
+  Cisco's EIGRP, but is designed to work well not only in wired networks but
+  also in wireless mesh networks, and has been extended with support for
+  overlay networks. Babel is an IETF standard protocol (RFC 8966).
 endef
 
 define Package/babeld/conffiles
@@ -49,6 +46,7 @@ endef
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
        LDLIBS="" \
+       LDLIBS+="-lubus -lubox"
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin