babeld: Improve Makefile formatting
[feed/routing.git] / babeld / Makefile
index ba8d14d7058fc3af90cf5b501cd152036be4ae0b..8e7f589745bf0cd30eefa46e035251e0d3625fd3 100644 (file)
@@ -8,13 +8,17 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.8.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=b0602a6124ddafb37225bd1a2d8abb13
+PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
+PKG_HASH:=202d99c275604507c6ce133710522f1ddfb62cb671c26f1ac2d3ab44af3d5bc4
+
+PKG_MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
+       Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
 PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -23,19 +27,18 @@ define Package/babeld
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=A loop-free distance-vector routing protocol
-  URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
-  MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  URL:=https://www.irif.fr/~jch/software/babel/
+  DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
- Babel is a loop-avoiding distance-vector routing protocol roughly based
- on DSDV and AODV, but with provisions for link cost estimation and
- redistribution of routes from other routing protocols.
- While it is optimised for wireless mesh networks, Babel will also work
- efficiently on wired networks. It will generate between 1.2 and 2.4 times
- the amount of routing traffic that RIPng would generate, while
- never counting to infinity.
 Babel is a loop-avoiding distance-vector routing protocol roughly based
 on DSDV and AODV, but with provisions for link cost estimation and
 redistribution of routes from other routing protocols.
 While it is optimised for wireless mesh networks, Babel will also work
 efficiently on wired networks. It will generate between 1.2 and 2.4 times
 the amount of routing traffic that RIPng would generate, while
 never counting to infinity.
 endef
 
 define Package/babeld/conffiles
@@ -45,6 +48,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin