babeld: Update to version 1.8.5
[feed/routing.git] / babeld / Makefile
index e9393100e6d5571fbe35aa71f743eb0e0b11237e..972862ceaaf59146ac0e3e58b86c1a22a925ef54 100644 (file)
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.5.1
+PKG_VERSION:=1.8.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=20e3284d5ad291d7ba2ad91d5b47de10
+PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
+PKG_HASH:=202d99c275604507c6ce133710522f1ddfb62cb671c26f1ac2d3ab44af3d5bc4
+PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -22,9 +23,10 @@ define Package/babeld
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=A loop-free distance-vector routing protocol
-  URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
-  MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  URL:=https://www.irif.fr/~jch/software/babel/
+  MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
+              Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
+  DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
@@ -44,6 +46,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin