Merge pull request #213 from zorun/babeld_update_url
[feed/routing.git] / babeld / Makefile
index d7a9ddcc34f50e7af34adf321bbf48cd7195bf17..b46f4f2ed991b8d675e52ba8f567144cde7f34da 100644 (file)
@@ -8,12 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.5.0
+PKG_VERSION:=1.7.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=ac884beb644792bdb79f0042755820ee
+PKG_SOURCE_URL:=https://www.irif.univ-paris-diderot.fr/~jch/software/files/
+PKG_MD5SUM:=2f71794d4e67f8a5352164ce33611549
+PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -24,7 +25,7 @@ define Package/babeld
   TITLE:=A loop-free distance-vector routing protocol
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
@@ -44,6 +45,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin