miniupnpd: disable IGDv2 by default
[feed/routing.git] / babeld / Makefile
index ba8d14d7058fc3af90cf5b501cd152036be4ae0b..cd7f6e36a73fe5ee894598047b58f1d61a2aef3e 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.8.0
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=b0602a6124ddafb37225bd1a2d8abb13
+PKG_SOURCE_URL:=https://www.irif.fr/~jch/software/files/
+PKG_MD5SUM:=eb1c66c382e9181c418ebd84e52b5af2
 PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
@@ -23,9 +23,10 @@ define Package/babeld
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=A loop-free distance-vector routing protocol
-  URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
-  MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  URL:=https://www.irif.fr/~jch/software/babel/
+  MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>, \
+              Baptiste Jonglez <openwrt-pkg@bitsofnetworks.org>
+  DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
@@ -45,6 +46,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin