babeld: Fixed kmod-ipv6 dependency.
[feed/routing.git] / babeld / Makefile
index ba8d14d7058fc3af90cf5b501cd152036be4ae0b..d4b609cde09ae721003db4b38cbef32e245018cd 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.6.0
-PKG_RELEASE:=2
+PKG_VERSION:=1.6.1
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=b0602a6124ddafb37225bd1a2d8abb13
+PKG_MD5SUM:=74290f6c3678f314c79bdc0ab99d9f22
 PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
@@ -25,7 +25,7 @@ define Package/babeld
   TITLE:=A loop-free distance-vector routing protocol
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  DEPENDS:=+@IPV6
 endef
 
 define Package/babeld/description
@@ -45,6 +45,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin