batctl: improve version string
[feed/routing.git] / batctl / Makefile
index 0284c794a15bf26a75b3522387da587456195633..0a19592bb5fbc173e5a9a0b3bb91f598296c1e90 100644 (file)
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batctl
 
-PKG_VERSION:=2019.0
+PKG_VERSION:=2019.4
 PKG_RELEASE:=0
-PKG_HASH:=997721096ff396644e8d697ea7651e9d38243faf317bcea2661d4139ff58b531
+PKG_HASH:=a3564eb9727335352dc0cfa2f2b29474c2c837384689ac5fcb387784a56e7685
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
-PKG_LICENSE:=GPL-2.0
+PKG_LICENSE:=GPL-2.0-only ISC MIT
+PKG_LICENSE_FILES:=LICENSES/preferred/GPL-2.0 LICENSES/preferred/MIT LICENSES/deprecated/ISC
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
 
@@ -30,6 +31,13 @@ define Package/batctl/Default
   MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
 endef
 
+define Package/batctl/description
+batctl is a more intuitive managment utility for B.A.T.M.A.N.-Advanced.
+It is an easier method for configuring batman-adv and provides some
+additional tools for debugging as well. This package builds
+version $(PKG_VERSION) of the user space utility.
+endef
+
 define Package/batctl-tiny
 $(call Package/batctl/Default)
   TITLE:=B.A.T.M.A.N. Advanced user space configuration tool (Minimal)
@@ -38,25 +46,33 @@ $(call Package/batctl/Default)
   ALTERNATIVES:=100:/usr/sbin/batctl:/usr/libexec/batctl-tiny
 endef
 
+define Package/batctl-tiny/description
+$(Package/batctl/description)
+Only configuration relevant subcommands are enabled.
+endef
+
 define Package/batctl-default
 $(call Package/batctl/Default)
   TITLE:=B.A.T.M.A.N. Advanced user space configuration tool (Default)
   VARIANT:=default
-  ALTERNATIVES:=200:/usr/sbin/batctl:/usr/libexec/batctl-full
+  ALTERNATIVES:=200:/usr/sbin/batctl:/usr/libexec/batctl-default
+endef
+
+define Package/batctl-default/description
+$(Package/batctl/description)
+Standard subcommands for configuration and online debugging are enabled.
 endef
 
 define Package/batctl-full
 $(call Package/batctl/Default)
-  TITLE:=B.A.T.M.A.N. Advanced user space configuration tool (Minimal)
+  TITLE:=B.A.T.M.A.N. Advanced user space configuration tool (Full)
   VARIANT:=full
   ALTERNATIVES:=300:/usr/sbin/batctl:/usr/libexec/batctl-full
 endef
 
-define Package/batctl/description
-batctl is a more intuitive managment utility for B.A.T.M.A.N.-Advanced.
-It is an easier method for configuring batman-adv and provides some
-additional tools for debugging as well. This package builds
-version $(PKG_VERSION) of the user space utility.
+define Package/batctl-full/description
+$(Package/batctl/description)
+Subcommands for configuration, online and offline debugging are enabled.
 endef
 
 # The linker can identify unused sections of a binary when each symbol is stored
@@ -73,19 +89,12 @@ TARGET_LDFLAGS += -Wl,--gc-sections
 TARGET_CFLAGS  += -flto
 TARGET_LDFLAGS += -fuse-linker-plugin
 
-MAKE_BATCTL_ENV += \
-        CPPFLAGS="$(TARGET_CPPFLAGS)" \
-        CFLAGS="$(TARGET_CFLAGS)" \
-        LDFLAGS="$(TARGET_LDFLAGS)" \
+MAKE_VARS += \
         LIBNL_NAME="libnl-tiny" \
         LIBNL_GENL_NAME="libnl-tiny"
 
-MAKE_BATCTL_ARGS += \
-        REVISION="$(PKG_BATCTL_SHORTREV)" \
-        CC="$(TARGET_CC)" \
-        DESTDIR="$(PKG_INSTALL_DIR)" \
-        batctl install \
-        REVISION="openwrt-$(PKG_VERSION)-$(PKG_RELEASE)"
+MAKE_FLAGS += \
+        REVISION="$(PKG_VERSION)-openwrt-$(PKG_RELEASE)"
 
 config-n := \
        aggregation \
@@ -97,15 +106,18 @@ config-n := \
        claimtable \
        dat_cache \
        distributed_arp_table \
+       elp_interval \
        event \
        fragmentation \
        gateways \
        gw_mode \
+       hop_penalty \
        interface \
        isolation_mark \
-       log \
        loglevel \
        mcast_flags \
+       multicast_fanout \
+       multicast_forceflood \
        multicast_mode \
        nc_nodes \
        neighbors \
@@ -116,6 +128,7 @@ config-n := \
        routing_algo \
        statistics \
        tcpdump \
+       throughput_override \
        throughputmeter \
        traceroute \
        transglobal \
@@ -128,15 +141,20 @@ config-settings := \
        bonding \
        bridge_loop_avoidance \
        distributed_arp_table \
+       elp_interval \
        fragmentation \
        gw_mode \
+       hop_penalty \
        interface \
        isolation_mark \
        loglevel \
+       multicast_fanout \
+       multicast_forceflood \
        multicast_mode \
        network_coding \
        orig_interval \
        routing_algo \
+       throughput_override \
 
 config-tables := \
        backbonetable \
@@ -153,7 +171,6 @@ config-tables := \
 
 config-tools := \
        event \
-       log \
        ping \
        tcpdump \
        throughputmeter \
@@ -199,10 +216,7 @@ $(call ConfigVars,n)$(call ConfigVars,y)
 endef
 $(eval $(call shexport,batctl_config))
 
-define Build/Compile
-       $(MAKE_BATCTL_ENV) $(MAKE) -C "$(PKG_BUILD_DIR)" $(MAKE_BATCTL_ARGS) \
-               $$$$$(call shvar,batctl_config)
-endef
+MAKE_FLAGS += $$$$$(call shvar,batctl_config)
 
 define Package/batctl-tiny/install
        $(INSTALL_DIR) $(1)/usr/libexec