bird: update to v1.6.3
[feed/routing.git] / bird / Makefile
index cea4690194071df7166cf4b9a55937e52059aa57..f691add6d0e1e7b82309b541813ca36071bb1821 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,13 +7,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird
-PKG_VERSION:=1.4.0
+PKG_VERSION:=1.6.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
-PKG_MD5SUM:=4e5a47308335b1b0bf4691cac6c4174f
+PKG_MD5SUM:=39c51cf57c3ba8b5978b2a657ffa2f647ec7f3ae643e91cf42ee5cb070cf7e7c
 PKG_BUILD_DEPENDS:=libncurses libreadline
+PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+
+PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -29,6 +32,11 @@ define Package/birdc/Default
   DEPENDS:= +libreadline +libncurses
 endef
 
+define Package/birdcl/Default
+  TITLE:=The BIRD lightweight command-line client
+  URL:=http://bird.network.cz/
+endef
+
 define Package/bird/Default/description1
 BIRD is an internet routing daemon which manages TCP/IP routing tables
 with support of modern routing protocols, easy to use configuration
@@ -57,6 +65,14 @@ should install BIRD command-line client together with BIRD.
 
 endef
 
+define Package/bird/Default/description4
+This is a BIRD lightweight command-line client. It is used to send commands to BIRD,
+commands can perform simple actions such as enabling/disabling of
+protocols, telling BIRD to show various information, telling it to show
+a routing table filtered by a filter, or asking BIRD to reconfigure.
+
+endef
+
 define Package/bird4
 $(call Package/bird/Default)
   SECTION:=net
@@ -74,6 +90,15 @@ $(call Package/birdc/Default)
   DEPENDS+= +bird4
 endef
 
+define Package/birdcl4
+$(call Package/birdcl/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
+  TITLE+= (IPv4)
+  DEPENDS+= +bird4
+endef
+
 define Package/bird6
 $(call Package/bird/Default)
   SECTION:=net
@@ -91,6 +116,15 @@ $(call Package/birdc/Default)
   DEPENDS+= +bird6
 endef
 
+define Package/birdcl6
+$(call Package/birdcl/Default)
+  SECTION:=net
+  CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
+  TITLE+= (IPv6)
+  DEPENDS+= +bird6
+endef
+
 define Package/bird4/description
 $(call Package/bird/Default/description1)
 This is IPv4 version of BIRD, it supports OSPFv2, RIPv2 and BGP
@@ -104,6 +138,11 @@ $(call Package/bird/Default/description1)
 $(call Package/bird/Default/description3)
 endef
 
+define Package/birdcl4/description
+$(call Package/bird/Default/description1)
+$(call Package/bird/Default/description4)
+endef
+
 define Package/bird6/description
 $(call Package/bird/Default/description1)
 This is IPv6 version of BIRD, it supports OSPFv3, RIPng and BGP
@@ -117,14 +156,21 @@ $(call Package/bird/Default/description1)
 $(call Package/bird/Default/description3)
 endef
 
+define Package/birdcl6/description
+$(call Package/bird/Default/description1)
+$(call Package/bird/Default/description4)
+endef
+
 CONFIGURE_ARGS += --with-linux-headers="$(LINUX_DIR)"
 
+TARGET_CFLAGS+=-std=gnu89
+
 define Build/Template
 
 $(STAMP_BUILT)-$(2): $(STAMP_PREPARED)
        $(call Build/Configure/Default,$(3))
        $(call Build/Compile/Default,)
-       ( cd $(PKG_BUILD_DIR); mv -f bird bird$(2); mv -f birdc birdc$(2) )
+       ( cd $(PKG_BUILD_DIR); mv -f bird bird$(2); mv -f birdc birdc$(2); mv -f birdcl birdcl$(2) )
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
        touch $$@
 
@@ -133,7 +179,6 @@ $(STAMP_BUILT): $(STAMP_BUILT)-$(2)
 define Package/bird$(2)/install
        $(INSTALL_DIR)  $$(1)/usr/sbin
        $(INSTALL_BIN)  $$(PKG_BUILD_DIR)/bird$(2) $$(1)/usr/sbin/
-       $(INSTALL_BIN)  ./files/bird$(2)loop $$(1)/usr/sbin/
        $(INSTALL_DIR)  $$(1)/etc
        $(INSTALL_DATA) ./files/bird$(2).conf $$(1)/etc/
        $(INSTALL_DIR)  $$(1)/etc/init.d
@@ -150,6 +195,11 @@ define Package/birdc$(2)/install
        $(INSTALL_BIN) $$(PKG_BUILD_DIR)/birdc$(2) $$(1)/usr/sbin/
 endef
 
+define Package/birdcl$(2)/install
+       $(INSTALL_DIR) $$(1)/usr/sbin
+       $(INSTALL_BIN) $$(PKG_BUILD_DIR)/birdcl$(2) $$(1)/usr/sbin/
+endef
+
 endef
 
 
@@ -158,5 +208,7 @@ $(eval $(call Build/Template,bird6,6, --enable-ipv6))
 
 $(eval $(call BuildPackage,bird4))
 $(eval $(call BuildPackage,birdc4))
+$(eval $(call BuildPackage,birdcl4))
 $(eval $(call BuildPackage,bird6))
 $(eval $(call BuildPackage,birdc6))
+$(eval $(call BuildPackage,birdcl6))