bmx: Use repos from https://github.com/bmx-routing and remove bmx7 json-c patch
[feed/routing.git] / bmx7 / Makefile
index 02a62bcfb3db31e4a1064fa08bfec908489f29b9..8999d8d0e3765fe8bce318b67b9b98412d5a1164 100644 (file)
@@ -1,4 +1,3 @@
-#    Copyright (C) 2011 Fundacio Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net
 #
 #    This program is free software; you can redistribute it and/or modify
 #    it under the terms of the GNU General Public License as published by
 #
 #    This program is free software; you can redistribute it and/or modify
 #    it under the terms of the GNU General Public License as published by
@@ -28,12 +27,11 @@ PKG_NAME:=bmx7
 
 PKG_SOURCE_PROTO:=git
 
 
 PKG_SOURCE_PROTO:=git
 
-#PKG_SOURCE_URL:=git://bmx6.net/bmx6.git
-PKG_SOURCE_URL:=git://github.com/axn/bmx6.git
-#PKG_SOURCE_URL:=file:///usr/src/bmx6/bmx6.git
+PKG_SOURCE_URL:=git://github.com/bmx-routing/bmx7.git
+#PKG_SOURCE_URL:=file:///usr/src/bmx-routing/bmx7.git
 
 
-PKG_REV:=87e849ea9e4855fcdfcdf8ce92a049859335b794
-PKG_VERSION:=r2016071904
+PKG_REV:=a0b18da22d4195afdea82ac080eba02f1121f86b
+PKG_VERSION:=r2018010203
 PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
 PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
@@ -46,8 +44,9 @@ include $(INCLUDE_DIR)/package.mk
 
 TARGET_CFLAGS += $(FPIC)
 
 
 TARGET_CFLAGS += $(FPIC)
 
+MAKE_ARGS += EXTRA_CFLAGS="$(TARGET_CFLAGS) -I. -I$(STAGING_DIR)/usr/include -DCRYPTLIB=MBEDTLS_2_4_0 -DCORE_LIMIT=20000 -DTRAFFIC_DUMP -DNO_TRACE_FUNCTION_CALLS -DBMX7_LIB_IWINFO"
+
 MAKE_ARGS += \
 MAKE_ARGS += \
-        EXTRA_CFLAGS="$(TARGET_CFLAGS) -I. -I$(STAGING_DIR)/usr/include -DCRYPTLIB=POLARSSL_1_3_4 -DCORE_LIMIT=20000 -DTRAFFIC_DUMP -DNO_TRACE_FUNCTION_CALLS -DBMX7_LIB_IWINFO" \
         EXTRA_LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib -liwinfo" \
         GIT_REV="$(PKG_REV)" \
         CC="$(TARGET_CC)" \
         EXTRA_LDFLAGS="$(TARGET_LDFLAGS) -L$(STAGING_DIR)/usr/lib -liwinfo" \
         GIT_REV="$(PKG_REV)" \
         CC="$(TARGET_CC)" \
@@ -59,9 +58,9 @@ define Package/bmx7/Default
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=BMX7 layer 3 routing daemon
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=BMX7 layer 3 routing daemon
-  URL:=http://bmx6.net/
+  URL:=http://github.com/bmx-routing/bmx7
   MAINTAINER:=Axel Neumann <neumann@cgws.de>
   MAINTAINER:=Axel Neumann <neumann@cgws.de>
-  DEPENDS:=+zlib +libpolarssl +libiwinfo
+  DEPENDS:=+zlib +libmbedtls +libiwinfo
 endef
 
 define Package/bmx7/description
 endef
 
 define Package/bmx7/description