cjdns: support libc other than uClibc
[feed/routing.git] / cjdns / Makefile
index 3253532669588bc8c0144efb11e45cb83350e51b..9744d7b5486d1a326988a50962835e08e2beef1a 100644 (file)
@@ -36,8 +36,14 @@ endef
 define Build/Configure
 endef
 
 define Build/Configure
 endef
 
+PKG_DO_VARS:=
+
 ifneq ($(CONFIG_KERNEL_SECCOMP_FILTER),y)
 ifneq ($(CONFIG_KERNEL_SECCOMP_FILTER),y)
-PKG_DO_VARS:=Seccomp_NO=1
+PKG_DO_VARS+= Seccomp_NO=1
+endif
+
+ifneq ($(CONFIG_USE_UCLIBC),)
+PKG_DO_VARS+= UCLIBC=1
 endif
 
 define Build/Compile
 endif
 
 define Build/Compile
@@ -47,7 +53,6 @@ define Build/Compile
        LDFLAGS="$(TARGET_LDFLAGS)" \
        SYSTEM="linux" \
        TARGET_ARCH="$(CONFIG_ARCH)" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        SYSTEM="linux" \
        TARGET_ARCH="$(CONFIG_ARCH)" \
-       UCLIBC=1 \
        SSP_SUPPORT="$(CONFIG_SSP_SUPPORT)" \
        $(PKG_DO_VARS) \
        $(PKG_BUILD_DIR)/do
        SSP_SUPPORT="$(CONFIG_SSP_SUPPORT)" \
        $(PKG_DO_VARS) \
        $(PKG_BUILD_DIR)/do