cjdns: 20.1 -> 20.2
[feed/routing.git] / cjdns / Makefile
index a81b49144cfe66598ccbddcd68088c09ffa49edf..cd5ca905574e1780848b6ff0680efb70bd6fae2d 100644 (file)
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cjdns
-PKG_VERSION:=0.17
-PKG_RELEASE:=2
+PKG_VERSION:=20.2
+PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=https://github.com/hyperboria/cjdns.git
+PKG_SOURCE_URL:=https://github.com/cjdelisle/cjdns.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=40e87d9419c19063e772e39c7c59a8a8771c5ee8
+PKG_SOURCE_VERSION:=77259a49e5bc7ca7bc6dca5bd423e02be563bdc5
 PKG_LICENSE:=GPL-3.0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
@@ -36,7 +36,7 @@ define Package/cjdns
        CATEGORY:=Network
        SUBMENU:=Routing and Redirection
        TITLE:=Encrypted near-zero-conf mesh routing protocol
-       URL:=https://github.com/hyperboria/cjdns
+       URL:=https://github.com/cjdelisle/cjdns
        MAINTAINER:=Lars Gierth <larsg@systemli.org>
        DEPENDS:=@IPV6 +kmod-tun +libnl-tiny +libpthread +librt \
                +libuci-lua +lua-bencode +dkjson +luasocket +lua-sha2
@@ -54,7 +54,7 @@ define Package/cjdns-tests
        CATEGORY:=Network
        SUBMENU:=Routing and Redirection
        TITLE:=cjdns test cases
-       URL:=https://github.com/hyperboria/cjdns
+       URL:=https://github.com/cjdelisle/cjdns
        MAINTAINER:=Lars Gierth <larsg@systemli.org>
        DEPENDS:=+libpthread +librt
 endef
@@ -77,18 +77,21 @@ PKG_DO_VARS+= UCLIBC=1
 endif
 
 define Build/Compile
+       $(INSTALL_DIR) $(PKG_BUILD_DIR)/tmp
+       (cd $(PKG_BUILD_DIR) && \
        CROSS="true" \
        CC="$(TARGET_CC)" \
        AR="$(TARGET_AR)" \
        RANLIB="$(TARGET_RANLIB)" \
-       CFLAGS="$(TARGET_CFLAGS)" \
+       CFLAGS="$(TARGET_CFLAGS) -U_FORTIFY_SOURCE" \
        LDFLAGS="$(TARGET_LDFLAGS)" \
        SYSTEM="linux" \
        TARGET_ARCH="$(CONFIG_ARCH)" \
        SSP_SUPPORT="$(CONFIG_SSP_SUPPORT)" \
        GYP_ADDITIONAL_ARGS="-f make-linux" \
+       CJDNS_BUILD_TMPDIR="$(PKG_BUILD_DIR)/tmp" \
        $(PKG_DO_VARS) \
-       $(PKG_BUILD_DIR)/do
+       exec ./do)
 endef
 
 define Package/cjdns/install