hnetd: fix mdns-support
[feed/routing.git] / hnetd / Makefile
index a79a6afdd402f3139e7667da0c8593a0fd5db296..c9d7ce6e78ae59b46a2dd2d766c3b3b3414ed022 100644 (file)
@@ -7,9 +7,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=hnetd
-PKG_SOURCE_VERSION:=5c5394cd375a8b1013ef2db30b298fa60fae8a1a
-PKG_VERSION:=2014-04-14-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=1
+PKG_SOURCE_VERSION:=91aaab8bdd4de8bc96ad906673a79a6600cf93ac
+PKG_VERSION:=2014-09-02-$(PKG_SOURCE_VERSION)
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/sbyx/hnetd.git
@@ -39,10 +39,23 @@ endef
 define Package/hnet-full
   SECTION:=net
   CATEGORY:=Network
-  TITLE:=HNCP Homenet metapackage (hnetd + ohybridproxy + babels)
+  TITLE:=HNCP Homenet metapackage
   URL:=https://github.com/sbyx/hnetd
-  DEPENDS:=+odhcpd +odhcp6c +netifd +hnetd +ohybridproxy +babels
-  DEPENDS+=+@IPV6
+  DEPENDS:=+hnetd +luci-app-hnet
+  # Routing
+  DEPENDS+=+babels
+  # Service discovery
+  DEPENDS+=+ohybridproxy
+  # Distributed PCP support
+  DEPENDS+=+miniupnpd +minimalist-pcproxy
+endef
+
+define Package/luci-app-hnet
+  SECTION:=luci
+  CATEGORY:=LuCI
+  SUBMENU:=3. Applications
+  TITLE:=HNCP Homenet configuration and visualization
+  DEPENDS:=+hnetd
 endef
 
 define Package/hnetd/description
@@ -57,10 +70,13 @@ define Package/hnetd/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/hnetd $(1)/usr/sbin/
        $(INSTALL_DIR) $(1)/lib/netifd/proto
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/openwrt/hnet.sh $(1)/lib/netifd/proto
-       ln -s hnetd $(1)/usr/sbin/hnet-call
+       ln -s hnetd $(1)/usr/sbin/hnet-ifresolve
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/hnetd.init $(1)/etc/init.d/hnetd
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DATA) ./files/hnet.config $(1)/etc/config/hnet
        $(INSTALL_BIN) ./files/ohp-script $(1)/usr/sbin/hnetd-ohp-script
+       $(INSTALL_BIN) ./files/pcp-script $(1)/usr/sbin/hnetd-pcp-script
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/generic/hnetd-routing $(1)/usr/sbin/hnetd-routing
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/hnetd.defaults $(1)/etc/uci-defaults/x-hnetd.defaults
@@ -70,6 +86,13 @@ define Package/hnet-full/install
        true
 endef
 
+define Package/luci-app-hnet/install
+       $(INSTALL_DIR) $(1)/usr/lib/lua/luci
+       $(INSTALL_DIR) $(1)/www
+       $(CP) -R $(PKG_BUILD_DIR)/openwrt/luci/luasrc/* $(1)/usr/lib/lua/luci/
+       $(CP) -R $(PKG_BUILD_DIR)/openwrt/luci/htdocs/* $(1)/www/
+endef
+
 define Package/hnetd/postinst
 #!/bin/sh
 [ -n "$${IPKG_INSTROOT}" ] || {
@@ -83,3 +106,4 @@ endef
 
 $(eval $(call BuildPackage,hnetd))
 $(eval $(call BuildPackage,hnet-full))
+$(eval $(call BuildPackage,luci-app-hnet))