mcproxy: update to latest version (#339)
[feed/routing.git] / mcproxy / Makefile
index b96268ab065db7d93eb1dab92f120594ff375e94..4b6cf4eaf4b6275c2d63d50d35ce2e8aa7500f31 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2014-2017 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,13 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mcproxy
-PKG_SOURCE_VERSION:=986523a5d714be5cf6f65e4399045cbfecd415fd
-PKG_VERSION:=2014-03-25-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=93b5ace42268160ebbfff4c61818fb15fa2d9b99
+PKG_VERSION:=2017-08-24-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/mcproxy/mcproxy.git
 PKG_MAINTAINER:=Steven Barth <cyrus@openwrt.org>
+PKG_LICENSE:=GPL-2.0+
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -25,9 +26,10 @@ include $(INCLUDE_DIR)/cmake.mk
 define Package/mcproxy
   SECTION:=net
   CATEGORY:=Network
+  SUBMENU:=Routing and Redirection
   TITLE:=Multicast Proxy for IGMP/MLD
   URL:=http://mcproxy.realmv6.org
-  DEPENDS:=+libpthread +libstdcpp
+  DEPENDS:=+libpthread +libstdcpp @(!GCC_VERSION_4_4&&!GCC_VERSION_4_6)
 endef
 
 define Package/mcproxy/description
@@ -38,11 +40,15 @@ endef
 
 define Package/mcproxy/conffiles
 /etc/mcproxy.conf
+/etc/config/mcproxy
 endef
 
 define Package/mcproxy/install
+       $(INSTALL_DIR) $(1)/etc
+       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc/mcproxy.conf
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) ./files/mcproxy.config $(1)/etc/config/mcproxy
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_CONF) ./files/mcproxy.conf $(1)/etc
        $(INSTALL_BIN) ./files/mcproxy.init $(1)/etc/init.d/mcproxy
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/mcproxy-bin $(1)/usr/sbin/mcproxy