nodogsplash: Release 3.2.0
[feed/routing.git] / nodogsplash / Makefile
index 7b05e630663d7ff962b4059727e8988b6c3bf7b2..786891b3467e2516afbde9f74106fa800e353f18 100644 (file)
@@ -7,14 +7,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=1.0.2
-PKG_RELEASE:=1
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://github.com/nodogsplash/nodogsplash.git
-PKG_SOURCE_VERSION:=9ef7d5fc16351585baf65877776d19cf85bf3031
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_VERSION:=3.2.0
+PKG_RELEASE:=0
+
+PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
+PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
+PKG_HASH:=c9712c21c2cc88724a8104fa63edd4f69d31af24db0fad84db6105fae2d65809
+PKG_BUILD_DIR:=$(BUILD_DIR)/nodogsplash-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
 
@@ -25,34 +26,41 @@ define Package/nodogsplash
        SUBMENU:=Captive Portals
        SECTION:=net
        CATEGORY:=Network
-       DEPENDS:=+libpthread +iptables-mod-ipopt
+       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd-no-ssl
        TITLE:=Open public network gateway daemon
        URL:=https://github.com/nodogsplash/nodogsplash
+       CONFLICTS:=nodogsplash2
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash offers a simple way to open a free hotspot providing
-       restricted access to an internet connection.
+       Nodogsplash is a Captive Portal that offers a simple way to
+       provide restricted access to the Internet by showing a splash
+       page to the user before Internet access is granted.
+       It also incorporates an API that allows the creation of
+       sophisticated authentication applications.
 endef
 
 define Package/nodogsplash/install
+       $(CP) ./files/* $(1)/
+
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/nodogsplash
-       $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_CONF) files/nodogsplash.config $(1)/etc/config/nodogsplash
+       $(INSTALL_DIR) $(1)/etc/nodogsplash/htdocs/images
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/status.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/nodogsplash/htdocs/images/
+endef
 
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)/htdocs/images
-       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/$(PKG_NAME)/htdocs/
-       $(CP) $(PKG_BUILD_DIR)/resources/infoskel.html $(1)/etc/$(PKG_NAME)/htdocs/
-       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/$(PKG_NAME)/htdocs/images/
+define Package/nodogsplash/postrm
+#!/bin/sh
+uci delete firewall.nodogsplash
+uci commit firewall
 endef
 
 define Package/nodogsplash/conffiles
-/etc/nodogsplash/nodogsplash.conf
+/etc/config/nodogsplash
 endef
 
 $(eval $(call BuildPackage,nodogsplash))