nodogsplash: Release 3.2.0
[feed/routing.git] / nodogsplash / Makefile
index ffe35b9cff88a9495de5c6a90a356319d05a5b04..786891b3467e2516afbde9f74106fa800e353f18 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Copyright (C) 2013 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -8,8 +6,18 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.9_beta9.9.8
-PKG_RELEASE:=1
+PKG_FIXUP:=autoreconf
+PKG_VERSION:=3.2.0
+PKG_RELEASE:=0
+
+PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
+PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
+PKG_HASH:=c9712c21c2cc88724a8104fa63edd4f69d31af24db0fad84db6105fae2d65809
+PKG_BUILD_DIR:=$(BUILD_DIR)/nodogsplash-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
+PKG_BUILD_PARALLEL:=1
+PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -18,41 +26,41 @@ define Package/nodogsplash
        SUBMENU:=Captive Portals
        SECTION:=net
        CATEGORY:=Network
-       DEPENDS:=+libpthread +iptables-mod-ipopt
+       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd-no-ssl
        TITLE:=Open public network gateway daemon
-       URL:=https://github.com/mwarning/nodogsplash
+       URL:=https://github.com/nodogsplash/nodogsplash
+       CONFLICTS:=nodogsplash2
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash offers a simple way to open a free hotspot providing
-       restricted access to an internet connection.
-endef
-
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       git clone https://github.com/mwarning/nodogsplash.git $(PKG_BUILD_DIR)
+       Nodogsplash is a Captive Portal that offers a simple way to
+       provide restricted access to the Internet by showing a splash
+       page to the user before Internet access is granted.
+       It also incorporates an API that allows the creation of
+       sophisticated authentication applications.
 endef
 
-#for sources inside the package
-#define Build/Prepare
-#      mkdir -p $(PKG_BUILD_DIR)
-#      $(CP) ./src/* $(PKG_BUILD_DIR)/
-#endef
-
 define Package/nodogsplash/install
+       $(CP) ./files/* $(1)/
+
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_DIR) $(1)/etc/nodogsplash/htdocs/images
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/status.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/nodogsplash/htdocs/images/
+endef
 
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)/htdocs/images
-       $(CP) $(PKG_BUILD_DIR)/resources/nodogsplash.conf $(1)/etc/$(PKG_NAME)/
-       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/$(PKG_NAME)/htdocs/
-       $(CP) $(PKG_BUILD_DIR)/resources/infoskel.html $(1)/etc/$(PKG_NAME)/htdocs/
-       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/$(PKG_NAME)/htdocs/images/
+define Package/nodogsplash/postrm
+#!/bin/sh
+uci delete firewall.nodogsplash
+uci commit firewall
 endef
 
+define Package/nodogsplash/conffiles
+/etc/config/nodogsplash
+endef
 
 $(eval $(call BuildPackage,nodogsplash))