alfred: upgrade package to latest release 2018.0
[feed/routing.git] / nodogsplash / Makefile
index d630dba76496654f0d25b71e1961c82246103958..b0f9da8112e348ba643497a4b6864b9e301c91a5 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Copyright (C) 2013 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -9,13 +7,13 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=0.9_beta9.9.9
-PKG_RELEASE:=3
+PKG_VERSION:=1.0.2
+PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://github.com/nodogsplash/nodogsplash.git
-PKG_SOURCE_VERSION:=v0.9_beta9.9.9
+PKG_SOURCE_VERSION:=9ef7d5fc16351585baf65877776d19cf85bf3031
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
 PKG_LICENSE:=GPL-2.0+
@@ -43,10 +41,9 @@ define Package/nodogsplash/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/$(PKG_NAME)
-
-       $(INSTALL_DIR) $(1)/etc/uci-defaults
-       $(INSTALL_CONF) ./files/nodogsplash.migrate $(1)/etc/uci-defaults/30_nodogsplash
+       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/nodogsplash
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) files/nodogsplash.config $(1)/etc/config/nodogsplash
 
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)/htdocs/images
        $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/$(PKG_NAME)/htdocs/