nodogsplash: code cleanup, add option gatewayinterface, allow uci and manual configra...
[feed/routing.git] / nodogsplash / Makefile
index 69ac310242827a06bff71c15da9e7082809a18a8..ca223b7390a392387ec71ec1d0c6210636079be0 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
+# Copyright (C) 2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,68 +8,49 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.9_beta9.9.6
-PKG_RELEASE:=3
+PKG_FIXUP:=autoreconf
+PKG_VERSION:=0.9_beta9.9.9
+PKG_RELEASE:=4
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/ \
-       http://kokoro.ucsd.edu/nodogsplash/old/
-PKG_MD5SUM:=3ba0d862b4d63ecf97f16176a486faed
-
-PKG_FIXUP:=autoreconf
+PKG_SOURCE_URL:=git://github.com/nodogsplash/nodogsplash.git
+PKG_SOURCE_VERSION:=v0.9_beta9.9.9
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
+PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
+
 define Package/nodogsplash
-  SUBMENU:=Captive Portals
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libpthread +iptables-mod-ipopt
-  TITLE:=Open public network gateway daemon
-  URL:=http://kokoro.ucsd.edu/nodogsplash/
+       SUBMENU:=Captive Portals
+       SECTION:=net
+       CATEGORY:=Network
+       DEPENDS:=+libpthread +iptables-mod-ipopt
+       TITLE:=Open public network gateway daemon
+       URL:=https://github.com/nodogsplash/nodogsplash
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an
-       internet connection. It is intended for use on wireless access points running OpenWRT
-       (but may also work on other Linux-based devices).
-endef
-
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --enable-static \
-               --enable-shared \
-       )
-endef
-
-define Build/Compile
-       $(call Build/Compile/Default, \
-               mkinstalldirs="$(INSTALL_DIR)")
-endef
-
-define Build/Install
-       mkdir -p $(PKG_INSTALL_DIR)/usr/{share{,/doc/$(PKG_NAME)-$(PKG_VERSION)},lib,include{,/nodogsplash},bin,sbin}/
-       $(call Build/Install/Default, \
-               mkinstalldirs="$(INSTALL_DIR)" \
-               install)
+       Nodogsplash offers a simple way to open a free hotspot providing
+       restricted access to an internet connection.
 endef
 
 define Package/nodogsplash/install
        $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME)/
-       $(SED) 's,br0,br-lan,' $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
-       $(CP) $(PKG_BUILD_DIR)/htdocs $(1)/etc/$(PKG_NAME)/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
+
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "imq"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "ipt_IMQ"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "sch_htb"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/nodogsplash
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) files/nodogsplash.config $(1)/etc/config/nodogsplash
+
+       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)/htdocs/images
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/$(PKG_NAME)/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/infoskel.html $(1)/etc/$(PKG_NAME)/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/$(PKG_NAME)/htdocs/images/
 endef
 
 define Package/nodogsplash/conffiles