nodogsplash: code cleanup, add option gatewayinterface, allow uci and manual configra...
[feed/routing.git] / nodogsplash / Makefile
index d1d9212682d070d23194d018fd704f6486214a71..ca223b7390a392387ec71ec1d0c6210636079be0 100644 (file)
@@ -9,15 +9,16 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=0.9_beta9.9.9-pre
-PKG_RELEASE:=1
+PKG_VERSION:=0.9_beta9.9.9
+PKG_RELEASE:=4
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=git://github.com/nodogsplash/nodogsplash.git
-PKG_SOURCE_VERSION:=master
+PKG_SOURCE_VERSION:=v0.9_beta9.9.9
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_BUILD_PARALLEL:=1
+PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -42,15 +43,18 @@ define Package/nodogsplash/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
        $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/$(PKG_NAME)
+       $(INSTALL_BIN) files/nodogsplash.init $(1)/etc/init.d/nodogsplash
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_CONF) files/nodogsplash.config $(1)/etc/config/nodogsplash
 
        $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)/htdocs/images
-       $(CP) $(PKG_BUILD_DIR)/resources/nodogsplash.conf $(1)/etc/$(PKG_NAME)/
        $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/$(PKG_NAME)/htdocs/
        $(CP) $(PKG_BUILD_DIR)/resources/infoskel.html $(1)/etc/$(PKG_NAME)/htdocs/
        $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/$(PKG_NAME)/htdocs/images/
 endef
 
+define Package/nodogsplash/conffiles
+/etc/nodogsplash/nodogsplash.conf
+endef
 
 $(eval $(call BuildPackage,nodogsplash))
-