[mcproxy] Split patches.
[feed/routing.git] / nodogsplash / Makefile
index ffe35b9cff88a9495de5c6a90a356319d05a5b04..dd2b1e415abbc6db8b2ae4249326dbb840507432 100644 (file)
@@ -8,8 +8,16 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
+PKG_FIXUP:=autoreconf
 PKG_VERSION:=0.9_beta9.9.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=git://github.com/nodogsplash/nodogsplash.git
+PKG_SOURCE_VERSION:=v0.9_beta9.9.8
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -20,7 +28,7 @@ define Package/nodogsplash
        CATEGORY:=Network
        DEPENDS:=+libpthread +iptables-mod-ipopt
        TITLE:=Open public network gateway daemon
-       URL:=https://github.com/mwarning/nodogsplash
+       URL:=https://github.com/nodogsplash/nodogsplash
 endef
 
 define Package/nodogsplash/description
@@ -28,17 +36,6 @@ define Package/nodogsplash/description
        restricted access to an internet connection.
 endef
 
-define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-       git clone https://github.com/mwarning/nodogsplash.git $(PKG_BUILD_DIR)
-endef
-
-#for sources inside the package
-#define Build/Prepare
-#      mkdir -p $(PKG_BUILD_DIR)
-#      $(CP) ./src/* $(PKG_BUILD_DIR)/
-#endef
-
 define Package/nodogsplash/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
@@ -56,3 +53,4 @@ endef
 
 
 $(eval $(call BuildPackage,nodogsplash))
+