nodogsplash: Add missing install directories (#460)
[feed/routing.git] / nodogsplash / Makefile
index 59d64a9d46fbc2359664c24c7de0b38fff1584cd..f14d945b09c0db717b03ec57459770f846441e08 100644 (file)
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
-PKG_VERSION:=3.1.0
-PKG_RELEASE:=0
+PKG_VERSION:=3.3.0
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
 PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
-PKG_HASH:=07363f76de6ca5bde5e98f5218e67150164174d2117936b3d57ac7ab01e7b413
+PKG_HASH:=ad89af14086982ebb07da6dd079c10e93e31af149e06611649d0dbee79cb8e67
 PKG_BUILD_DIR:=$(BUILD_DIR)/nodogsplash-$(PKG_VERSION)
 
 PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
@@ -26,28 +26,39 @@ define Package/nodogsplash
        SUBMENU:=Captive Portals
        SECTION:=net
        CATEGORY:=Network
-       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd-no-ssl
+       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd
        TITLE:=Open public network gateway daemon
        URL:=https://github.com/nodogsplash/nodogsplash
        CONFLICTS:=nodogsplash2
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash offers a simple way to open a free hotspot providing
-       restricted access to an internet connection.
+       Nodogsplash is a Captive Portal that offers a simple way to
+       provide restricted access to the Internet by showing a splash
+       page to the user before Internet access is granted.
+       It also incorporates an API that allows the creation of
+       sophisticated authentication applications.
 endef
 
 define Package/nodogsplash/install
-       $(CP) ./files/* $(1)/
 
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
        $(INSTALL_DIR) $(1)/etc/nodogsplash/htdocs/images
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DIR) $(1)/usr/lib/nodogsplash
        $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.css $(1)/etc/nodogsplash/htdocs/
        $(CP) $(PKG_BUILD_DIR)/resources/status.html $(1)/etc/nodogsplash/htdocs/
        $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/nodogsplash/htdocs/images/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/config/nodogsplash $(1)/etc/config/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/init.d/nodogsplash $(1)/etc/init.d/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/uci-defaults/40_nodogsplash $(1)/etc/uci-defaults/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/usr/lib/nodogsplash/restart.sh $(1)/usr/lib/nodogsplash/
 endef
 
 define Package/nodogsplash/postrm