nodogsplash: Add missing install directories (#460)
[feed/routing.git] / nodogsplash / Makefile
index 69ac310242827a06bff71c15da9e7082809a18a8..f14d945b09c0db717b03ec57459770f846441e08 100644 (file)
@@ -1,6 +1,4 @@
 #
-# Copyright (C) 2007-2012 OpenWrt.org
-#
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
@@ -8,72 +6,69 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nodogsplash
-PKG_VERSION:=0.9_beta9.9.6
-PKG_RELEASE:=3
+PKG_FIXUP:=autoreconf
+PKG_VERSION:=3.3.0
+PKG_RELEASE:=1
 
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://kokoro.ucsd.edu/nodogsplash/ \
-       http://kokoro.ucsd.edu/nodogsplash/old/
-PKG_MD5SUM:=3ba0d862b4d63ecf97f16176a486faed
+PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
+PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
+PKG_HASH:=ad89af14086982ebb07da6dd079c10e93e31af149e06611649d0dbee79cb8e67
+PKG_BUILD_DIR:=$(BUILD_DIR)/nodogsplash-$(PKG_VERSION)
 
-PKG_FIXUP:=autoreconf
+PKG_MAINTAINER:=Moritz Warning <moritzwarning@web.de>
 PKG_BUILD_PARALLEL:=1
-PKG_INSTALL:=1
+PKG_LICENSE:=GPL-2.0+
 
 include $(INCLUDE_DIR)/package.mk
 
+
 define Package/nodogsplash
-  SUBMENU:=Captive Portals
-  SECTION:=net
-  CATEGORY:=Network
-  DEPENDS:=+libpthread +iptables-mod-ipopt
-  TITLE:=Open public network gateway daemon
-  URL:=http://kokoro.ucsd.edu/nodogsplash/
+       SUBMENU:=Captive Portals
+       SECTION:=net
+       CATEGORY:=Network
+       DEPENDS:=+libpthread +iptables-mod-ipopt +libmicrohttpd
+       TITLE:=Open public network gateway daemon
+       URL:=https://github.com/nodogsplash/nodogsplash
+       CONFLICTS:=nodogsplash2
 endef
 
 define Package/nodogsplash/description
-       Nodogsplash offers a simple way to open a free hotspot providing restricted access to an
-       internet connection. It is intended for use on wireless access points running OpenWRT
-       (but may also work on other Linux-based devices).
+       Nodogsplash is a Captive Portal that offers a simple way to
+       provide restricted access to the Internet by showing a splash
+       page to the user before Internet access is granted.
+       It also incorporates an API that allows the creation of
+       sophisticated authentication applications.
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default,\
-               --enable-static \
-               --enable-shared \
-       )
-endef
+define Package/nodogsplash/install
 
-define Build/Compile
-       $(call Build/Compile/Default, \
-               mkinstalldirs="$(INSTALL_DIR)")
-endef
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/nodogsplash $(1)/usr/bin/
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/ndsctl $(1)/usr/bin/
 
-define Build/Install
-       mkdir -p $(PKG_INSTALL_DIR)/usr/{share{,/doc/$(PKG_NAME)-$(PKG_VERSION)},lib,include{,/nodogsplash},bin,sbin}/
-       $(call Build/Install/Default, \
-               mkinstalldirs="$(INSTALL_DIR)" \
-               install)
+       $(INSTALL_DIR) $(1)/etc/nodogsplash/htdocs/images
+       $(INSTALL_DIR) $(1)/etc/config
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_DIR) $(1)/usr/lib/nodogsplash
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.css $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/status.html $(1)/etc/nodogsplash/htdocs/
+       $(CP) $(PKG_BUILD_DIR)/resources/splash.jpg $(1)/etc/nodogsplash/htdocs/images/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/config/nodogsplash $(1)/etc/config/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/init.d/nodogsplash $(1)/etc/init.d/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/etc/uci-defaults/40_nodogsplash $(1)/etc/uci-defaults/
+       $(CP) $(PKG_BUILD_DIR)/openwrt/nodogsplash/files/usr/lib/nodogsplash/restart.sh $(1)/usr/lib/nodogsplash/
 endef
 
-define Package/nodogsplash/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
-       $(INSTALL_DIR) $(1)/usr/lib/
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
-       $(INSTALL_DIR) $(1)/etc/$(PKG_NAME)
-       $(INSTALL_CONF) $(PKG_BUILD_DIR)/$(PKG_NAME).conf $(1)/etc/$(PKG_NAME)/
-       $(SED) 's,br0,br-lan,' $(1)/etc/$(PKG_NAME)/$(PKG_NAME).conf
-       $(CP) $(PKG_BUILD_DIR)/htdocs $(1)/etc/$(PKG_NAME)/
-       $(INSTALL_DIR) $(1)/etc/init.d
-       $(INSTALL_BIN) ./files/$(PKG_NAME).init $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "imq"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "ipt_IMQ"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
-       $(SED) 's,\(do_module_tests "sch_htb"\),#\1,' $(1)/etc/init.d/$(PKG_NAME)
+define Package/nodogsplash/postrm
+#!/bin/sh
+uci delete firewall.nodogsplash
+uci commit firewall
 endef
 
 define Package/nodogsplash/conffiles
-/etc/nodogsplash/nodogsplash.conf
+/etc/config/nodogsplash
 endef
 
 $(eval $(call BuildPackage,nodogsplash))