Update OONF to 0.14.1-1 307/head
authorHenning Rogge <henning.rogge@fkie.fraunhofer.de>
Tue, 13 Jun 2017 08:59:44 +0000 (10:59 +0200)
committerHenning Rogge <henning.rogge@fkie.fraunhofer.de>
Tue, 13 Jun 2017 09:00:08 +0000 (11:00 +0200)
oonf-dlep-proxy/Makefile
oonf-dlep-radio/Makefile
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile

index 4b95171975ab854120247ca2c08f2bea9724ec2f..28e16fd3e8b77aa6ab9ad92abe9ab06408c57b96 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.14.0
-PKG_REV:=9863631659b28df7f9e507786ffb77f0ab2ef58e
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 1f4b359f9e50dad9558d6556b9e9e868ec48aa19..4357e5b6fa58f2fc2cbb2f826012c6bc19c12551 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.14.0
-PKG_REV:=9863631659b28df7f9e507786ffb77f0ab2ef58e
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 8af701c345072ad6f650a061a4202acec4d3f91b..1cc037aff3ebc9a2a1ea2d2c94857d62b8b28006 100644 (file)
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
+       config OONF_GENERIC_HTTP
+               bool "http plugin enabled"
+               help
+                       The HTTP plugin allows HTTP access to all telnet commands.
+               default n
+
        config OONF_OLSRV2_MPR
                bool "MPR plugin enabled"
                help
index d77c530b25e5db98b1083c28065092579a380cf5..727bd16721b09ad05a36780fa52f5d0bc5a6b29f 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.14.0
-PKG_REV:=9863631659b28df7f9e507786ffb77f0ab2ef58e
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -25,9 +25,13 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
+        $(if $(filter y,$(CONFIG_OONF_GENERIC_HTTP)),http,) \
     ))
 
-CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
+BUILD_TYPE:= $(if $(filter y,$(CONFIG_DEBUG)),Debug,Release)
+
+CMAKE_OPTIONS=-D CMAKE_BUILD_TYPE:String=$(BUILD_TYPE) \
+              -D OONF_NO_WERROR:Bool=true \
               -D OONF_LOGGING_LEVEL:String=debug \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \