[bird] Cleanup unneeded files.
authorÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 17 Jan 2014 18:54:43 +0000 (19:54 +0100)
committerÁlvaro Fernández Rojas <noltari@gmail.com>
Fri, 17 Jan 2014 18:54:43 +0000 (19:54 +0100)
bird/Makefile
bird/files/bird4.init
bird/files/bird4loop [deleted file]
bird/files/bird6.init
bird/files/bird6loop [deleted file]

index cea4690194071df7166cf4b9a55937e52059aa57..cb4b2a19fefd97ae96dc272e1e59c056011514c6 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2014 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -133,7 +133,6 @@ $(STAMP_BUILT): $(STAMP_BUILT)-$(2)
 define Package/bird$(2)/install
        $(INSTALL_DIR)  $$(1)/usr/sbin
        $(INSTALL_BIN)  $$(PKG_BUILD_DIR)/bird$(2) $$(1)/usr/sbin/
-       $(INSTALL_BIN)  ./files/bird$(2)loop $$(1)/usr/sbin/
        $(INSTALL_DIR)  $$(1)/etc
        $(INSTALL_DATA) ./files/bird$(2).conf $$(1)/etc/
        $(INSTALL_DIR)  $$(1)/etc/init.d
index 18243bb9238fc3d5b2879ae6bfa57beb64e04d24..4fbd3022ae9bb36474e308c3bcc0a745265ffb5a 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 
 START=99
 STOP=10
@@ -11,11 +11,9 @@ BIRD="/usr/sbin/bird4 -c /etc/bird4.conf"
 
 start() {
        service_start $BIRD -d
-#      ( SERVICE_MATCH_NAME=1 service_start /usr/sbin/bird4loop )
 }
 
 stop() {
-#      ( SERVICE_MATCH_NAME=1 service_stop /usr/sbin/bird4loop )
        service_stop $BIRD
 }
 
diff --git a/bird/files/bird4loop b/bird/files/bird4loop
deleted file mode 100644 (file)
index 8154902..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-BIRD="/usr/sbin/bird4 -c /etc/bird4.conf"
-
-$BIRD -p || return 1
-
-. /lib/functions.sh
-. /lib/functions/service.sh
-
-SERVICE_DAEMONIZE=1
-SERVICE_WRITE_PID=1
-
-sig_handler() {
-       running=0
-       service_stop $BIRD
-}
-
-running=1
-trap sig_handler INT
-trap sig_handler TERM
-while [ $running -gt 0 ]; do
-       service_check $BIRD || service_start $BIRD -d "$@"
-       sleep 3
-done
index 67b32f177c3a73402429f81b67f1dfe129486460..9089e006c406db4affc6f465b61368f4a26c1fe4 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2010-2011 OpenWrt.org
+# Copyright (C) 2010-2014 OpenWrt.org
 
 START=99
 STOP=10
@@ -11,11 +11,9 @@ BIRD="/usr/sbin/bird6 -c /etc/bird6.conf"
 
 start() {
        service_start $BIRD -d
-#      ( SERVICE_MATCH_NAME=1 service_start /usr/sbin/bird6loop )
 }
 
 stop() {
-#      ( SERVICE_MATCH_NAME=1 service_stop /usr/sbin/bird6loop )
        service_stop $BIRD
 }
 
diff --git a/bird/files/bird6loop b/bird/files/bird6loop
deleted file mode 100644 (file)
index 510add4..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/bin/sh
-
-BIRD="/usr/sbin/bird6 -c /etc/bird6.conf"
-
-$BIRD -p || return 1
-
-. /lib/functions.sh
-. /lib/functions/service.sh
-
-SERVICE_DAEMONIZE=1
-SERVICE_WRITE_PID=1
-
-sig_handler() {
-       running=0
-       service_stop $BIRD
-}
-
-running=1
-trap sig_handler INT
-trap sig_handler TERM
-while [ $running -gt 0 ]; do
-       service_check $BIRD || service_start $BIRD -d "$@"
-       sleep 3
-done