bird: Update to 1.3.11 and fix build issues
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Oct 2013 19:29:15 +0000 (19:29 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Oct 2013 19:30:45 +0000 (19:30 +0000)
Based on patch by Álvaro Fernández Rojas <noltari@gmail.com>

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
bird/Makefile
bird/files/bird4.init
bird/files/bird4loop
bird/files/bird6.init
bird/files/bird6loop
bird/patches/0001-change_config_name.patch [deleted file]

index 6565f0106453571153a3c48c481200c8592d560f..dfccbba7b06b257932ed09b3782a4b9ac2400be6 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird
-PKG_VERSION:=1.3.7
+PKG_VERSION:=1.3.11
 PKG_RELEASE:=1
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
-PKG_MD5SUM:=c400b008ef834d9e7288dcdbe41b7c15
+PKG_MD5SUM:=8ad2eb997fb8251bc5b24cf32619571b
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
index 8ac5e759137440cb64e1c514756658aa50e838e9..18243bb9238fc3d5b2879ae6bfa57beb64e04d24 100644 (file)
@@ -1,21 +1,24 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2010-2011 OpenWrt.org
 
-START=50
+START=99
+STOP=10
 
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
+BIRD="/usr/sbin/bird4 -c /etc/bird4.conf"
+
 start() {
-       service_start /usr/sbin/bird4 -d
+       service_start $BIRD -d
 #      ( SERVICE_MATCH_NAME=1 service_start /usr/sbin/bird4loop )
 }
 
 stop() {
 #      ( SERVICE_MATCH_NAME=1 service_stop /usr/sbin/bird4loop )
-       service_stop /usr/sbin/bird4
+       service_stop $BIRD
 }
 
 reload() {
-       service_reload /usr/sbin/bird4
+       service_reload $BIRD
 }
index 074a9a2e3a941f7f435b28cbd8ffc84fcae0ce54..8154902b9c79bdf03c0f1c2202f036b7f2b1a067 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-BIRD=/usr/sbin/bird4
+BIRD="/usr/sbin/bird4 -c /etc/bird4.conf"
 
 $BIRD -p || return 1
 
index 2efb4f0963c181106e50bd69c33ad984624d58c9..67b32f177c3a73402429f81b67f1dfe129486460 100644 (file)
@@ -1,21 +1,24 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2010-2011 OpenWrt.org
 
-START=50
+START=99
+STOP=10
 
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
+BIRD="/usr/sbin/bird6 -c /etc/bird6.conf"
+
 start() {
-       service_start /usr/sbin/bird6 -d
+       service_start $BIRD -d
 #      ( SERVICE_MATCH_NAME=1 service_start /usr/sbin/bird6loop )
 }
 
 stop() {
 #      ( SERVICE_MATCH_NAME=1 service_stop /usr/sbin/bird6loop )
-       service_stop /usr/sbin/bird6
+       service_stop $BIRD
 }
 
 reload() {
-       service_reload /usr/sbin/bird6
+       service_reload $BIRD
 }
index c01cf2ee0efb9fd6b7ff80f38e89a3a9012a3d75..510add4edf7e2065ff39ad4184569e903a718c3a 100644 (file)
@@ -1,6 +1,6 @@
 #!/bin/sh
 
-BIRD=/usr/sbin/bird6
+BIRD="/usr/sbin/bird6 -c /etc/bird6.conf"
 
 $BIRD -p || return 1
 
diff --git a/bird/patches/0001-change_config_name.patch b/bird/patches/0001-change_config_name.patch
deleted file mode 100644 (file)
index 98532f7..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
-diff --git a/sysdep/config.h b/sysdep/config.h
-index 03399bd..bc5eb77 100644
---- a/sysdep/config.h
-+++ b/sysdep/config.h
-@@ -46,11 +46,11 @@ typedef u16 word;
- #  endif
- #else
- #  ifdef DEBUGGING
--#    define PATH_CONFIG "bird.conf"
--#    define PATH_CONTROL_SOCKET "bird.ctl"
-+#    define PATH_CONFIG "bird4.conf"
-+#    define PATH_CONTROL_SOCKET "bird4.ctl"
- #  else
--#    define PATH_CONFIG PATH_CONFIG_DIR "/bird.conf"
--#    define PATH_CONTROL_SOCKET PATH_CONTROL_SOCKET_DIR "/bird.ctl"
-+#    define PATH_CONFIG PATH_CONFIG_DIR "/bird4.conf"
-+#    define PATH_CONTROL_SOCKET PATH_CONTROL_SOCKET_DIR "/bird4.ctl"
- #  endif
- #endif