olsrd: find_most_recent_plugin_libary() fix sorting
authorBastian Bittorf <bb@npl.de>
Fri, 24 Feb 2017 14:12:19 +0000 (15:12 +0100)
committerBastian Bittorf <bb@npl.de>
Fri, 24 Feb 2017 14:12:19 +0000 (15:12 +0100)
olsrd/files/olsrd.init

index 7f7aecc..8e562c1 100644 (file)
@@ -473,16 +473,17 @@ olsrd_write_hna6() {
 find_most_recent_plugin_libary()
 {
        local library="$1"      # e.g. 'olsrd_dyn_gw' or 'olsrd_txtinfo.so.1.1'
-       local file unixtime
+       local file file_fullpath unixtime
 
        for file in "/lib/$library"* "/usr/lib/$library"* "/usr/local/lib/$library"*; do {
                [ -f "$file" ] && {
+                       file_fullpath="$file"
                        file="$( basename "$file" )"
                        # make sure that we do not select
                        # 'olsrd_dyn_gw_plain.so.0.4' if user wants
                        # 'olsrd_dyn_gw.so.0.5' -> compare part before 1st dot
                        [ "${library%%.*}" = "${file%%.*}" ] && {
-                               unixtime="$( date +%s -r "$file" )"
+                               unixtime="$( date +%s -r "$file_fullpath" )"
                                echo "$unixtime $file"
                        }
                }