Merge pull request #330 from lynxis/rb_mrd6
authorSteven Barth <steven@midlink.org>
Wed, 13 Dec 2017 18:46:44 +0000 (19:46 +0100)
committerGitHub <noreply@github.com>
Wed, 13 Dec 2017 18:46:44 +0000 (19:46 +0100)
mrd6: remove build timestamp

olsrd/Makefile
oonf-dlep-proxy/Makefile
oonf-dlep-radio/Makefile
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile
smcroute/Makefile
smcroute/patches/001-Make-output-of-build-id-optional.patch [new file with mode: 0644]

index 9091efbc378e678db58e3e4e166400d5145f3c41..4aaccb2ca51a3eae116883ec052cf17162bf1b3c 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=olsrd
-PKG_VERSION:=0.9.6.1
+PKG_VERSION:=0.9.6.2
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=v0.9.6.1
+PKG_SOURCE_VERSION:=v0.9.6.2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 PKG_MIRROR_MD5SUM:=
 
@@ -119,7 +119,7 @@ endef
 
 define Package/olsrd-mod-pud
   $(call Package/olsrd/template)
-  DEPENDS:=olsrd +libgps +ncurses
+  DEPENDS:=olsrd +libgps
   TITLE:=Position Update Distribution plugin
 endef
 
index 2f36eaabe6b0974bb3c23db08b81610e424269f3..28e16fd3e8b77aa6ab9ad92abe9ab06408c57b96 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index ac1f19c47e095e8b2d278cbd4fd89742cb3f6668..4357e5b6fa58f2fc2cbb2f826012c6bc19c12551 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 7cda51805c8159de564d7112744c1f9551b2580b..1cc037aff3ebc9a2a1ea2d2c94857d62b8b28006 100644 (file)
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
+       config OONF_GENERIC_HTTP
+               bool "http plugin enabled"
+               help
+                       The HTTP plugin allows HTTP access to all telnet commands.
+               default n
+
+       config OONF_OLSRV2_MPR
+               bool "MPR plugin enabled"
+               help
+                       The MPR plugin reduce the routing graph to limit the overhead of the OLSRv2 protocol
+               default n
+
        endmenu
index 9b8e988509bc039a2375d7aa2c524a15ed4582d6..727bd16721b09ad05a36780fa52f5d0bc5a6b29f 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -24,9 +24,14 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_ROUTE_MODIFIER)),route_modifier,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
+        $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
+        $(if $(filter y,$(CONFIG_OONF_GENERIC_HTTP)),http,) \
     ))
 
-CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
+BUILD_TYPE:= $(if $(filter y,$(CONFIG_DEBUG)),Debug,Release)
+
+CMAKE_OPTIONS=-D CMAKE_BUILD_TYPE:String=$(BUILD_TYPE) \
+              -D OONF_NO_WERROR:Bool=true \
               -D OONF_LOGGING_LEVEL:String=debug \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \
index 1a5a2027b8133df893f0ea66039ab87d49561d88..a11bfd97a9ee530658a7df91526e8ee5092b567f 100644 (file)
@@ -8,13 +8,15 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=smcroute
 PKG_VERSION:=2.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0+
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=ftp://troglobit.com/smcroute/
 PKG_MD5SUM:=cbf478e52ab9ae411adca41b9d22f68a
 
+PKG_FIXUP:=autoreconf
+
 include $(INCLUDE_DIR)/package.mk
 
 define Package/smcroute
diff --git a/smcroute/patches/001-Make-output-of-build-id-optional.patch b/smcroute/patches/001-Make-output-of-build-id-optional.patch
new file mode 100644 (file)
index 0000000..bffecc9
--- /dev/null
@@ -0,0 +1,65 @@
+Author: Micha Lenk <micha@lenk.info>
+Date: Thu, 7 May 2015 21:54:31 +0200
+Description: Make output of build id optional
+ With free software, anyone can inspect the source code for malicious flaws.
+ But the software is often provided as binary packages to its users. The idea
+ of “deterministic” or “reproducible” builds is to empower anyone to verify
+ that no flaws have been introduced during the build process by reproducing
+ byte-for-byte identical binary packages from a given source.  See also:
+ https://wiki.debian.org/ReproducibleBuilds
+ .
+ Prior to this change a timestamp generated at build time is included in the
+ output of 'smcroute -v'. As a result the binary is unreproducible.
+ .
+ With this change, users that still want 'smcroute -v' to include a build id
+ can run './configure --enable-build-id' to get the build id back (or even
+ specify a custom build id).
+Origin: upstream, https://github.com/troglobit/smcroute/commit/73f6f14907f709e40689216291621ad26cd22ecd
+Bug-Debian: https://bugs.debian.org/784694
+Last-Update: 2017-08-08
+
+---
+ configure.ac | 9 ++++++++-
+ smcroute.c   | 6 +++++-
+ 2 files changed, 13 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 556d958..eb4a291 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -181,7 +181,14 @@ AC_COMPILE_IFELSE(
+   [AC_MSG_RESULT(no)])
+ # Add build number to config.h.in
+-AC_DEFINE_UNQUOTED([BUILD], "`date +%y%m%d`", [Build number, abbreviated date.])
++AC_ARG_ENABLE([build-id],
++  [AS_HELP_STRING([--enable-build-id@<:@=ID@:>@],
++              [show build id in output of 'smcroute -v'])],
++  [AS_IF([test "x$enableval" = "xyes" ],
++    [build_id=`date +%y%m%d`],
++    [build_id=$enableval])
++   AC_DEFINE_UNQUOTED([BUILD], "$build_id", [Build number, abbreviated date.])])
++
+ # Checks for library functions.
+ AC_FUNC_FORK
+diff --git a/smcroute.c b/smcroute.c
+index 7bd3c72..0287458 100644
+--- a/smcroute.c
++++ b/smcroute.c
+@@ -46,7 +46,11 @@ static const char *conf_file = SMCROUTE_SYSTEM_CONF;
+ extern char *__progname;
+ static const char version_info[] =
+-      "SMCRoute version " PACKAGE_VERSION " build " BUILD "\n";
++      "SMCRoute version " PACKAGE_VERSION
++#ifdef BUILD
++        " build " BUILD
++#endif
++        "\n";
+ static const char usage_info[] =
+       "Usage: smcroute [OPTIONS]... [ARGS]...\n"
+-- 
+2.11.0
+