nodogsplash: check if TrafficControl is enabled before testing imq module requirement.
authorGui Iribarren <gui@altermundi.net>
Sun, 15 Dec 2013 11:31:50 +0000 (08:31 -0300)
committerGui Iribarren <gui@altermundi.net>
Sun, 15 Dec 2013 11:37:03 +0000 (08:37 -0300)
This avoids failing to start in current OpenWrt Attitude Adjustment and trunk,
which lack IMQ support (and WONTFIX). Suggested in the issue discussed in:
http://ml.ninux.org/pipermail/nodogsplash/2013-May/000009.html

Signed-off-by: Gui Iribarren <gui@altermundi.net>
nodogsplash/Makefile
nodogsplash/files/nodogsplash.init

index a599823203a6845fd5718820677b1807742de073..dd2b1e415abbc6db8b2ae4249326dbb840507432 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
 PKG_VERSION:=0.9_beta9.9.8
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
 PKG_VERSION:=0.9_beta9.9.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index 7eba60b1661ba1c8281f049f6e0c0637a4fd3956..588e20ed8b90bed2b6abec064753364d5f86d1ac 100644 (file)
@@ -13,6 +13,7 @@
 
 IPT=/usr/sbin/iptables
 WD_DIR=/usr/bin
 
 IPT=/usr/sbin/iptables
 WD_DIR=/usr/bin
+NDS_CONF=/etc/nodogsplash/nodogsplash.conf
 OPTIONS=""
 START=65
 STOP=65
 OPTIONS=""
 START=65
 STOP=65
@@ -168,9 +169,11 @@ test_module() {
 
     do_module_tests "ipt_mac"
     do_module_tests "ipt_mark"
 
     do_module_tests "ipt_mac"
     do_module_tests "ipt_mark"
-    # if not using traffic control,
-    # you can comment out the following 3 lines:
-    do_module_tests "imq" "numdevs=2"
-    do_module_tests "ipt_IMQ"
-    do_module_tests "sch_htb"
+
+    # test for imq modules, only if TrafficControl is enabled in conf
+    if ( grep -q '^[[:space:]]*TrafficControl[[:space:]]\+yes' "$NDS_CONF" ) ; then
+        do_module_tests "imq" "numdevs=2"
+        do_module_tests "ipt_IMQ"
+        do_module_tests "sch_htb"
+    fi
 }
 }