batmand: Use git repository to retrieve sources
authorSven Eckelmann <sven@narfation.org>
Wed, 18 Jan 2017 12:34:16 +0000 (13:34 +0100)
committerSven Eckelmann <sven@narfation.org>
Mon, 23 Jan 2017 18:47:52 +0000 (19:47 +0100)
The current package is build around the subversion repository which does
not exist anymore. The package can therefore be moved to the git repository
to have an official source for the revision used in OpenWrt.

The SVN version of batman r1439 was actually r1435. The git export of revision
r1435 is referenced by this commit. The version number was only increased
to 1440 to create a new source tarball. SVN revision r1440 is not a commit
for batman and therefore no code changes in batman was done in r1440.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batmand/Makefile
batmand/patches/100-2.6.36.patch

index 3822ddecbe3ee7240e2c5fb82ecba731de69bbc7..c4284caf6bb73fd9762a9472aa3a683e52c02882 100644 (file)
@@ -9,18 +9,22 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=batmand
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=batmand
-PKG_REV:=1439
-PKG_VERSION:=r$(PKG_REV)
-PKG_RELEASE:=4
-PKG_EXTRA_CFLAGS=-DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA -DREVISION_VERSION=\"\ rv$(PKG_REV)\" -D_GNU_SOURCE
 
 
-PKG_HASH:=3c72ce2aae889944acfc898434c6e9573b20815862db1938f3132cc50b669667
-PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://sources.lede-project.org https://downloads.openwrt.org/sources
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.open-mesh.org/batmand.git
+PKG_REV:=b67a7087b51d7a5e90d27ac39116d1f57257c86e
+PKG_VERSION:=1440
+PKG_RELEASE:=0
 PKG_LICENSE:=GPL-2.0
 
 PKG_LICENSE:=GPL-2.0
 
-PKG_KMOD_BUILD_DIR:=$(PKG_BUILD_DIR)/batman/linux/modules
+PKG_SOURCE_VERSION:=$(PKG_REV)
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+
+PKG_EXTRA_CFLAGS=-DDEBUG_MALLOC -DMEMORY_USAGE -DPROFILE_DATA -DREVISION_VERSION=\"\ rv$(PKG_REV)\" -D_GNU_SOURCE
+
+PKG_KMOD_BUILD_DIR:=$(PKG_BUILD_DIR)/linux/modules
 
 include $(INCLUDE_DIR)/package.mk
 
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -81,7 +85,7 @@ define Build/Configure
 endef
 
 ifneq ($(DEVELOPER)$(CONFIG_PACKAGE_batmand),)
 endef
 
 ifneq ($(DEVELOPER)$(CONFIG_PACKAGE_batmand),)
-       BUILD_BATMAND := $(MAKE) -C $(PKG_BUILD_DIR)/batman $(MAKE_BATMAND_ARGS)
+       BUILD_BATMAND := $(MAKE) -C $(PKG_BUILD_DIR) $(MAKE_BATMAND_ARGS)
 endif
        
 ifneq ($(DEVELOPER)$(CONFIG_PACKAGE_kmod-batgat),)
 endif
        
 ifneq ($(DEVELOPER)$(CONFIG_PACKAGE_kmod-batgat),)
index 566c23b66b35b0c361d59f1deee8493572bebc87..13318e0b3449c9232544ac35fc5dd0b1be30ae23 100644 (file)
@@ -2,8 +2,8 @@
  batman/linux/modules/gateway.c |   19 +++++++++++++++++++
  1 file changed, 19 insertions(+)
 
  batman/linux/modules/gateway.c |   19 +++++++++++++++++++
  1 file changed, 19 insertions(+)
 
---- batmand-r1439.orig/batman/linux/modules/gateway.c
-+++ batmand-r1439/batman/linux/modules/gateway.c
+--- batmand-r1439.orig/linux/modules/gateway.c
++++ batmand-r1439/linux/modules/gateway.c
 @@ -29,6 +29,7 @@ static struct class *batman_class;
  static int batgat_open(struct inode *inode, struct file *filp);
  static int batgat_release(struct inode *inode, struct file *file);
 @@ -29,6 +29,7 @@ static struct class *batman_class;
  static int batgat_open(struct inode *inode, struct file *filp);
  static int batgat_release(struct inode *inode, struct file *file);