Merge pull request #305 from HRogge/master
authorBastian Bittorf <bb@npl.de>
Wed, 13 Dec 2017 11:42:03 +0000 (12:42 +0100)
committerGitHub <noreply@github.com>
Wed, 13 Dec 2017 11:42:03 +0000 (12:42 +0100)
OONF 0.14.1-1

oonf-dlep-proxy/Makefile
oonf-dlep-radio/Makefile
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile

index 2f36eaabe6b0974bb3c23db08b81610e424269f3..28e16fd3e8b77aa6ab9ad92abe9ab06408c57b96 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index ac1f19c47e095e8b2d278cbd4fd89742cb3f6668..4357e5b6fa58f2fc2cbb2f826012c6bc19c12551 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
index 7cda51805c8159de564d7112744c1f9551b2580b..1cc037aff3ebc9a2a1ea2d2c94857d62b8b28006 100644 (file)
                        The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
                default n
 
+       config OONF_GENERIC_HTTP
+               bool "http plugin enabled"
+               help
+                       The HTTP plugin allows HTTP access to all telnet commands.
+               default n
+
+       config OONF_OLSRV2_MPR
+               bool "MPR plugin enabled"
+               help
+                       The MPR plugin reduce the routing graph to limit the overhead of the OLSRv2 protocol
+               default n
+
        endmenu
index 9b8e988509bc039a2375d7aa2c524a15ed4582d6..727bd16721b09ad05a36780fa52f5d0bc5a6b29f 100644 (file)
@@ -1,8 +1,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.13.0
-PKG_REV:=9f941b25e1ac806db9d41e9892a5cf361bfe98f5
+PKG_VERSION:=0.14.1-1
+PKG_REV:=d86825c0bdf144db706da444be7b0a2e8722b54d
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -24,9 +24,14 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_ROUTE_MODIFIER)),route_modifier,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
+        $(if $(filter y,$(CONFIG_OONF_OLSRV2_MPR)),mpr,) \
+        $(if $(filter y,$(CONFIG_OONF_GENERIC_HTTP)),http,) \
     ))
 
-CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
+BUILD_TYPE:= $(if $(filter y,$(CONFIG_DEBUG)),Debug,Release)
+
+CMAKE_OPTIONS=-D CMAKE_BUILD_TYPE:String=$(BUILD_TYPE) \
+              -D OONF_NO_WERROR:Bool=true \
               -D OONF_LOGGING_LEVEL:String=debug \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \