Add remotecontrol plugin to selectable Olsrd2 plugins
authorHenning Rogge <hrogge@gmail.com>
Thu, 5 May 2016 13:21:03 +0000 (14:21 +0100)
committerHenning Rogge <hrogge@gmail.com>
Thu, 5 May 2016 13:21:03 +0000 (14:21 +0100)
oonf-olsrd2/Config.in
oonf-olsrd2/Makefile

index f46831b3dd2b9af18674fea3510f6517f33e5be8..7cda51805c8159de564d7112744c1f9551b2580b 100644 (file)
                        The dlep_router plugin can receive linklayer metadata over the DLEP protocol. 
                default n
 
+       config OONF_GENERIC_REMOTECONTROL
+               bool "remotecontrol plugin enabled"
+               help
+                       The remotecontrol plugin allows you to control configuration and logging over the telnet plugin. Be careful not to open this functionality over the network without securing it.
+               default n
+
        endmenu
index 69cd97bf7964a44d04571a20e421cae1e4332f41..5a576d7dd52144d56059e85e2c423656d36bf353 100644 (file)
@@ -23,6 +23,7 @@ CMAKE_OPTIONAL_PLUGINS:= $(subst $(SPACE),;,$(strip \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_LAN_IMPORT)),lan_import,) \
         $(if $(filter y,$(CONFIG_OONF_OLSRV2_ROUTE_MODIFIER)),route_modifier,) \
         $(if $(filter y,$(CONFIG_OONF_GENERIC_DLEP_ROUTER)),dlep_router,) \
+        $(if $(filter y,$(CONFIG_OONF_GENERIC_REMOTECONTROL)),remotecontrol,) \
     ))
 
 CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \