mrd6: remove build timestamp 330/head
authorAlexander Couzens <lynxis@fe80.eu>
Sat, 2 Dec 2017 00:42:24 +0000 (01:42 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Sat, 2 Dec 2017 00:42:44 +0000 (01:42 +0100)
Build timestamp prevents reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
mrd6/Makefile
mrd6/patches/103-Make-build-reproducible.patch [new file with mode: 0644]

index a20ea26ab2a1da0d79418cb1f881e655c21c6e70..c4863ed4644c4f3d52eb38e5b58211ec257f3326 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=mrd6
 PKG_SOURCE_VERSION:=c805eb33255dbc0b6647d463c6c67d1c9d3105a0
 PKG_VERSION:=2013-11-30-$(PKG_SOURCE_VERSION)
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://github.com/hugosantos/mrd6.git
diff --git a/mrd6/patches/103-Make-build-reproducible.patch b/mrd6/patches/103-Make-build-reproducible.patch
new file mode 100644 (file)
index 0000000..e0a32e6
--- /dev/null
@@ -0,0 +1,45 @@
+From deb013d93c3ce78891386637d6b3300289130df6 Mon Sep 17 00:00:00 2001
+From: Thomas Preud'homme <robotux@celest.fr>
+Date: Sun, 7 Aug 2016 22:28:50 +0100
+Subject: Make build reproducible
+
+Remove build date from the binary so that two builds on different dates
+are binary identical.
+
+Origin: upstream, https://github.com/hugosantos/mrd6/commit/14f27d5528a3e4c8e5369bdee0e35961a2491661
+Forwarded: https://github.com/hugosantos/mrd6/pull/30
+Last-Update: 2016-08-09
+Applied-Upstream: commit: 14f27d5528a3e4c8e5369bdee0e35961a2491661
+---
+ src/Makefile | 1 -
+ src/mrd.cpp  | 2 --
+ 2 files changed, 3 deletions(-)
+
+--- a/src/Makefile
++++ b/src/Makefile
+@@ -185,7 +185,6 @@ endif
+ $(MRD_VERSION_CPP): $(SOURCES) Makefile Makefile.options
+       @set -e; mkdir -p $(dir $@); \
+               echo '/* This file is automatically generated */' > $(MRD_VERSION_CPP); \
+-              echo 'const char *BuildDate = "$(NOW)";' >> $(MRD_VERSION_CPP)
+ $(MODULES_CPP): Makefile Makefile.options
+       @set -e; mkdir -p $(dir $@); \
+--- a/src/mrd.cpp
++++ b/src/mrd.cpp
+@@ -75,7 +75,6 @@
+ mrd *g_mrd = 0;
+-extern const char *BuildDate;
+ static const char *VersionInfo = "mrd6 0.10.0";
+ static const char *defaultconffiles[] = {
+@@ -2335,7 +2334,6 @@ bool mrd::socket_regs(base_stream &out,
+ void mrd::show_base_info(base_stream &out) const {
+       out.xprintf("Version: %s\n", VersionInfo);
+-      out.xprintf("Build date: %s\n", BuildDate);
+ }
+ bool mrd::show_info(base_stream &out, const std::vector<std::string> &ctx) {