bmx7: update to 7.1.1 507/head
authorPaul Spooren <mail@aparcar.org>
Tue, 27 Aug 2019 08:03:09 +0000 (22:03 -1000)
committerPaul Spooren <mail@aparcar.org>
Tue, 27 Aug 2019 08:03:09 +0000 (22:03 -1000)
Also clean up the Makefile

Signed-off-by: Paul Spooren <mail@aparcar.org>
bmx7/Makefile
bmx7/files/etc/config/bmx7
bmx7/files/etc/init.d/bmx7

index 7eca2b21f625269069dd4906c63d7b9a3add8b95..aa73ff2157bcc054a254787803215913ab08d265 100644 (file)
@@ -1,44 +1,20 @@
-#
-#    This program is free software; you can redistribute it and/or modify
-#    it under the terms of the GNU General Public License as published by
-#    the Free Software Foundation; either version 2 of the License, or
-#    (at your option) any later version.
-#
-#    This program is distributed in the hope that it will be useful,
-#    but WITHOUT ANY WARRANTY; without even the implied warranty of
-#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#    GNU General Public License for more details.
-#
-#    You should have received a copy of the GNU General Public License along
-#    with this program; if not, write to the Free Software Foundation, Inc.,
-#    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-#    The full GNU General Public License is included in this distribution in
-#    the file called "COPYING".
-#
-# Contibutors:
-#      Axel Neumann, Simó Albert i Beltran, Pau Escrich
-#
-
-
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bmx7
+PKG_VERSION:=7.1.1
+PKG_RELEASE:=1
 
-PKG_SOURCE_PROTO:=git
-
-PKG_SOURCE_URL:=https://github.com/bmx-routing/bmx7.git
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://codeload.github.com/bmx-routing/bmx7/tar.gz/v$(PKG_VERSION)?
+PKG_HASH:=5f88df1c95e5cb842a6016bb1604e3e7f6097c63c5c9916edc3c84e96d4f5f65
+PKG_UNPACK:=$(TAR) -C $(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION) \
+       --strip-components=2 -xzf $(DL_DIR)/$(PKG_SOURCE) $(PKG_NAME)-$(PKG_VERSION)/src
 
-PKG_REV:=cc245a22e54b5e110384485f18d9b805c91d8b71
-PKG_MIRROR_HASH:=378228450b7790bb07b1d478f123e9196c1040d9f55ec42e83090249574a3d6b
-PKG_VERSION:=r2019030802
-PKG_RELEASE:=1
-PKG_LICENSE:=GPL-2.0
+PKG_MAINTAINER:=Axel Neumann <neumann@cgws.de>
+PKG_LICENSE:=GPL-2.0-or-later
+PKG_LICENSE_FILES:=LICENSE
 
-PKG_SOURCE_VERSION:=$(PKG_REV)
-PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE:=$(PKG_SOURCE_SUBDIR).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_SOURCE_SUBDIR)
+PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -58,13 +34,12 @@ define Package/bmx7/Default
   CATEGORY:=Network
   SUBMENU:=Routing and Redirection
   TITLE:=BMX7 layer 3 routing daemon
-  URL:=http://github.com/bmx-routing/bmx7
-  MAINTAINER:=Axel Neumann <neumann@cgws.de>
+  URL:=https://github.com/bmx-routing/bmx7
   DEPENDS:=+zlib +libmbedtls +libiwinfo
 endef
 
 define Package/bmx7/description
-BMX7 routing daemon supporting securely-entrusted IPv6 (and IPv4in6) routing
+  BMX7 routing daemon supporting securely-entrusted IPv6 (and IPv4in6) routing
 endef
 
 define Package/bmx7
@@ -81,7 +56,7 @@ endef
 define Package/bmx7-iwinfo
   $(call Package/bmx7/Default)
   DEPENDS:=bmx7 +libiwinfo
-  TITLE:=link characteristics plugin based on libiwinfo (recommended!)
+  TITLE:=link characteristics plugin via libiwinfo (recommended!)
 endef
 
 define Package/bmx7-topology
@@ -180,7 +155,6 @@ define Package/bmx7-table/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_table/bmx7_table.so $(1)/usr/lib/bmx7_table.so
 endef
 
-
 $(eval $(call BuildPackage,bmx7))
 $(eval $(call BuildPackage,bmx7-uci-config))
 $(eval $(call BuildPackage,bmx7-iwinfo))
index b92f52578ee15ad5126775933a96166046308cc1..648c9131a3b169027103ef7f45e455219d2ea60f 100644 (file)
@@ -1,11 +1,10 @@
-
 # for more information:
-# http://bmx6.net/projects/bmx6/wiki
+# https://github.com/bmx-routing/bmx7/
 # options execute: bmx7 --help
 
 config 'bmx7' 'general'
-#       option 'runtimeDir' '/var/run/bmx7'
-#      option 'trustedNodesDir' '/etc/bmx7/trustedNodes'
+#        option 'runtimeDir' '/var/run/bmx7'
+#        option 'trustedNodesDir' '/etc/bmx7/trustedNodes'
 
 #config 'plugin'
 #        option 'plugin' 'bmx7_config.so'
@@ -19,22 +18,18 @@ config 'bmx7' 'general'
 #config 'plugin'
 #        option 'plugin' 'bmx7_iwinfo.so'
 
-
 config 'dev' 'mesh_1'
         option 'dev' 'br-lan'
 
 config 'dev' 'mesh_2'
         option 'dev' 'wlan0'
 
-
-
 #config 'plugin'
 #        option 'plugin' 'bmx7_tun.so'
 
 #config 'plugin'
 #        option 'plugin' 'bmx7_table.so'
 
-
 #config 'tunDev' default
 #        option 'tunDev' 'default'
 #        option 'tun6Address' '2012:0:0:6666::1/64'
@@ -50,8 +45,3 @@ config 'dev' 'mesh_2'
 #        option 'tunOut' 'ip4'
 #        option 'network' '10.0.0.0/9'
 #        option 'minPrefixLen' '27'
-
-
-
-
-
index 74f896603cc30c9b8c6feeaff96e4b360e0e673f..2fb3a5508a5f1ca09477f74879c19cf4264cbc88 100755 (executable)
@@ -6,7 +6,7 @@ BIN=/usr/sbin/bmx7
 CONF=/etc/config/bmx7
 
 start_service() {
-       cd /root/
+       cd /root/ || return
        while pgrep -f mac80211.sh ; do sleep 1; done
 
        procd_open_instance "bmx7"