nodogsplash2: Add compatibility with mwan3 v2 359/head
authorRob White <rob@blue-wave.net>
Wed, 4 Apr 2018 21:44:19 +0000 (22:44 +0100)
committerGitHub <noreply@github.com>
Wed, 4 Apr 2018 21:44:19 +0000 (22:44 +0100)
nodogsplash2: Add compatibility with mwan3 version 2
Changes in mwan3 version 2 resulted in previous recommended fix for Nodogsplash to fail.
Setting fw_mark to use bits set "higher" than used in mwan3 solves the problem. This works also for all previous versions of Nodogsplash.
Author-name: Rob White
Signed-off-by: Rob White <rob@blue-wave.net>
nodogsplash2/files/nodogsplash.config

index b6ca368..37269bd 100644 (file)
@@ -73,6 +73,6 @@ config nodogsplash
   #list trustedmac '00:00:C0:01:D0:1D'
 
   # Set FW_MARK for compatibilty with other OpenWrt Packages eg mwan3, sqm etc.
-  list fw_mark_authenticated '520'
-  list fw_mark_trusted '510'
-  list fw_mark_blocked '500'
+  list fw_mark_authenticated '30000'
+  list fw_mark_trusted '20000'
+  list fw_mark_blocked '10000'