alfred: Add openwrt revision to internal version
authorSven Eckelmann <sven@narfation.org>
Sun, 7 Oct 2018 09:10:05 +0000 (11:10 +0200)
committerSven Eckelmann <sven@narfation.org>
Sun, 14 Oct 2018 14:04:31 +0000 (16:04 +0200)
OpenWrt is using a modified version of the software and these modifications
may introduce extra bugs (or behavior changes). It is also patched for
stable releases instead of switching to new releases. The revision should
therefore be added to the version number to make it easier understandable
which modified version the user may have installed.

Signed-off-by: Sven Eckelmann <sven@narfation.org>
alfred/Makefile

index a0d25a5e932d4aac15e5e66e5dd7156417eb85f7..ef260ad0f3198a255fee8a11949585de67fdaf91 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alfred
 PKG_VERSION:=2018.1
-PKG_RELEASE:=0
+PKG_RELEASE:=1
 PKG_HASH:=808fa6acf65c7a8e26405115176a5587157f746108cbe5dd974788eb05416d76
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -59,7 +59,8 @@ MAKE_ALFRED_FLAGS=\
        CONFIG_ALFRED_GPSD=$(if $(CONFIG_PACKAGE_ALFRED_GPSD),y,n) \
        CONFIG_ALFRED_CAPABILITIES=n \
         LIBNL_NAME="libnl-tiny" \
-        LIBNL_GENL_NAME="libnl-tiny"
+        LIBNL_GENL_NAME="libnl-tiny" \
+        REVISION="openwrt-$(PKG_VERSION)-$(PKG_RELEASE)"
 
 TARGET_CFLAGS  += -ffunction-sections -fdata-sections -flto
 TARGET_LDFLAGS += -Wl,--gc-sections -fuse-linker-plugin