replace DEPENDS=+@IPV6 with DEPENDS=@IPV6 191/head
authorAlexander Couzens <lynxis@fe80.eu>
Sun, 5 Jun 2016 00:13:13 +0000 (02:13 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Sun, 5 Jun 2016 01:07:20 +0000 (03:07 +0200)
The symbol IPV6 is a global config symbol, don't select it because it
will override the user decision of IPV6 as all other package in base do
it. A select (+) will also create a recursive dependency error.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
ahcpd/Makefile
babeld/Makefile
hnetd/Makefile
minimalist-pcproxy/Makefile
pimbd/Makefile

index 96b84753486399a9f4c0de2fc86edde1893903ea..043c60997fcb86475c3c9dc567d28fd21f3dbd9b 100644 (file)
@@ -25,7 +25,7 @@ define Package/ahcpd
   TITLE:=Ad-Hoc Configuration Protocol daemon
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/ahcp/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+@IPV6 +ip +librt
+  DEPENDS:=@IPV6 +ip +librt
 endef
 
 define Package/ahcpd/description
index 88a7886cf53629bc041ceead07925f1d16f8fb8b..69fb1e924ea99de6c237266e6078c25675d545e0 100644 (file)
@@ -25,7 +25,7 @@ define Package/babeld
   TITLE:=A loop-free distance-vector routing protocol
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+@IPV6
+  DEPENDS:=@IPV6
 endef
 
 define Package/babeld/description
index ebba0e7317923064efd4197bb47af2e6d48b9329..7fc8b9bbabc0031127d22dd90171ced285252b77 100644 (file)
@@ -38,7 +38,7 @@ define Package/hnetd/Default
   TITLE:=HNCP Homenet daemon - $(2)
   URL:=https://github.com/sbyx/hnetd
   DEPENDS:=+odhcpd +odhcp6c +netifd $(3)
-  DEPENDS+=+@IPV6
+  DEPENDS+=@IPV6
   VARIANT:=$1
 endef
 
index d0c2f06a41b5785f62d534c0833626e17b482cd5..36faa8d802e40f1ddc0a64722fcc66c4104b0805 100644 (file)
@@ -27,7 +27,7 @@ define Package/minimalist-pcproxy
   CATEGORY:=Network
   TITLE:=Lightweight PCP proxy
   URL:=https://github.com/fingon/minimalist-pcproxy
-  DEPENDS:=+libubox +@IPV6
+  DEPENDS:=+libubox @IPV6
 endef
 
 define Package/minimalist-pcproxy/description
index 55aec74dc390051632e41f713337c5fa17a406f4..9f971071b23434f842f72810d8962109f556f12c 100644 (file)
@@ -24,7 +24,7 @@ define Package/pimbd
   CATEGORY:=Network
   TITLE:=PIM BIDIR daemon
   URL:=https://github.com/Oryon/pimbd.git
-  DEPENDS+=+@IPV6
+  DEPENDS+=@IPV6
   DEPENDS+=netifd
 endef