alfred: upgrade package to latest release 2019.3
authorSven Eckelmann <sven@narfation.org>
Thu, 1 Aug 2019 15:37:03 +0000 (17:37 +0200)
committerSven Eckelmann <sven@narfation.org>
Thu, 1 Aug 2019 15:43:45 +0000 (17:43 +0200)
* avoid some kernel deprecation warning by using more generic netlink over
  sysfs

Signed-off-by: Sven Eckelmann <sven@narfation.org>
alfred/Makefile
alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch [new file with mode: 0644]

index 298226595fc2a16fe3db1791266d13642dfc03b3..aa43b67afdc3cbe9ce6938c57d6eccdc5d4157c3 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alfred
-PKG_VERSION:=2019.2
+PKG_VERSION:=2019.3
 PKG_RELEASE:=0
-PKG_HASH:=b656f0e9a97a99c7531b6d49ebfd663451c16cdd275bbf7d48ff8daed3880bf2
+PKG_HASH:=a4c37920de497701680abb55c49cdcd11e4e7135e0e7e79259c35492a3df4766
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
diff --git a/alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch b/alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch
new file mode 100644 (file)
index 0000000..3a982b8
--- /dev/null
@@ -0,0 +1,21 @@
+From: Sven Eckelmann <sven@narfation.org>
+Date: Thu, 1 Aug 2019 15:54:32 +0200
+Subject: alfred: vis: Add missing include for ifinfomsg
+
+Fixes: 0fc6e6674428 ("alfred: vis: Retrieve hardif status via generic netlink")
+Signed-off-by: Sven Eckelmann <sven@narfation.org>
+
+Origin: upstream, https://git.open-mesh.org/alfred.git/commit/ce26453bd72829ac9561acd8d3a06a3937341687
+
+diff --git a/vis/vis.c b/vis/vis.c
+index 947456343125458845f26dc38b53f18d6fd42d75..8df3056612d5da3678603a6e6430923c0c86cde0 100644
+--- a/vis/vis.c
++++ b/vis/vis.c
+@@ -10,6 +10,7 @@
+ #include <dirent.h>
+ #include <errno.h>
+ #include <getopt.h>
++#include <linux/rtnetlink.h>
+ #include <net/if.h>
+ #include <netinet/in.h>
+ #include <signal.h>