babeld: remove unnecessary librt linking & dependency
authorSteven Barth <steven@midlink.org>
Thu, 21 May 2015 06:24:18 +0000 (08:24 +0200)
committerMarkus Stenberg <markus.stenberg@iki.fi>
Thu, 21 May 2015 08:44:19 +0000 (11:44 +0300)
Signed-off-by: Steven Barth <steven@midlink.org>
Signed-off-by: Markus Stenberg <markus.stenberg@iki.fi>
babeld/Makefile

index ba8d14d..4247d91 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
 PKG_VERSION:=1.6.0
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
@@ -25,7 +25,7 @@ define Package/babeld
   TITLE:=A loop-free distance-vector routing protocol
   URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/babel/
   MAINTAINER:=Gabriel Kerneis <gabriel@kerneis.info>
-  DEPENDS:=+kmod-ipv6 +librt
+  DEPENDS:=+kmod-ipv6
 endef
 
 define Package/babeld/description
@@ -45,6 +45,7 @@ endef
 
 MAKE_FLAGS+= \
        CFLAGS="$(TARGET_CFLAGS)" \
+       LDLIBS="" \
 
 define Package/babeld/install
        $(INSTALL_DIR) $(1)/usr/sbin