luci-app-bmx6: bugfix format to query bmx6-info 550/head
authorpedrolab <531310-pedrolab@users.noreply.gitlab.com>
Fri, 21 Feb 2020 09:27:27 +0000 (10:27 +0100)
committerpedrolab <531310-pedrolab@users.noreply.gitlab.com>
Fri, 21 Feb 2020 10:05:34 +0000 (11:05 +0100)
- affected three tab luci templates (even with luci-compat installed)
- fixes #548
- as jow said in #548:
  - it might be that modern LuCI escapes it as %24 while old versions passed it
    on as-is
  - bmx6-info removes it anyway
    https://github.com/openwrt-routing/packages/blob/master/luci-app-bmx6/bmx6/www/cgi-bin/bmx6-info#L22
you can probably just remove it in all three tab templates

luci-app-bmx6/Makefile
luci-app-bmx6/bmx6/usr/lib/lua/luci/view/bmx6/nodes_j.htm
luci-app-bmx6/bmx6/usr/lib/lua/luci/view/bmx6/status_j.htm
luci-app-bmx6/bmx6/usr/lib/lua/luci/view/bmx6/tunnels_j.htm

index bb37c20dffb6a9ea7d379c89430312a0497385e9..6ee9390bb2f1d88c08a664a513968cd413f06a53 100644 (file)
@@ -20,7 +20,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luci-app-bmx6
-PKG_RELEASE:=5
+PKG_RELEASE:=6
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_LICENSE:=GPL-2.0+
index 8ebd5ee80a774d65c833f85c76f025f180e8e8f3..6a43e2d4509c82a0d50cadc51782b1fa68885711 100644 (file)
@@ -87,7 +87,7 @@
                  document.getElementById('extra-info').innerHTML = document.getElementById(id).innerHTML;
                }
        
-               new TablePooler(5,"/cgi-bin/bmx6-info", {'$neighbours':''}, "descriptions_table", function(st){
+               new TablePooler(5,"/cgi-bin/bmx6-info", {'neighbours':''}, "descriptions_table", function(st){
                  var infoicon = "<%=resource%>/bmx6/world_small.png";
                  var nodeicon = "<%=resource%>/bmx6/world.png";
                  var originators = st.neighbours[0].originators;
index bf21106f7947b0368b73512acbe555a380c72398..55015a04dfbcc6ff2e22800a55a6fcd2eddf1807 100644 (file)
@@ -63,7 +63,7 @@ Visit <a href="http://bmx6.net">bmx6.net</a> for more info.
 </div>
 
 <script type="text/javascript">//<![CDATA[
-               new TablePooler(5,"/cgi-bin/bmx6-info", {'$info':''}, "status_table", function(st){
+               new TablePooler(5,"/cgi-bin/bmx6-info", {'info':''}, "status_table", function(st){
                var res = Array();
                var sta = st.info[0].status;
                var ifaces = st.info[1].interfaces;
index 92b22a97d7ffdba35318e0e57c671283408f0cee..244d04f3d0c6c63bb38ccb93f50be26633f27270 100644 (file)
@@ -81,7 +81,7 @@
 </div>
 
 <script type="text/javascript">//<![CDATA[
-               new TablePooler(5,"/cgi-bin/bmx6-info", {'$tunnels':''}, "descriptions_table", function(st){
+               new TablePooler(5,"/cgi-bin/bmx6-info", {'tunnels':''}, "descriptions_table", function(st){
                   var tunicon = "<%=resource%>/icons/tunnel.png";
                   var tunicon_dis = "<%=resource%>/icons/tunnel_disabled.png";
                   var applyicon = "<%=resource%>/cbi/apply.gif";
@@ -91,7 +91,7 @@
                         var nodename = tunnel.remoteName.replace(/\..+$/,'');
                        var advnet = tunnel.advNet;
                        var status = '<img src="'+tunicon_dis+'"/>';
-                       
+
                        if ( tunnel.tunName != "---" ) status = '<img src="'+tunicon+'"/>';
                        if ( advnet == "0.0.0.0/0" ) advnet = "<b>Internet</b>";