alfred: upgrade package to latest release 2019.4
authorSven Eckelmann <sven@narfation.org>
Fri, 25 Oct 2019 21:29:06 +0000 (23:29 +0200)
committerSven Eckelmann <sven@narfation.org>
Fri, 25 Oct 2019 21:34:34 +0000 (23:34 +0200)
* fix build with musl

Signed-off-by: Sven Eckelmann <sven@narfation.org>
alfred/Makefile
alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch [deleted file]

index ef6d810af2299d325e83b6b36beb0bae5565578e..0786b2b4ed958c689db4abde8639ee184b6389c1 100644 (file)
@@ -8,9 +8,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alfred
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=alfred
-PKG_VERSION:=2019.3
-PKG_RELEASE:=2
-PKG_HASH:=a4c37920de497701680abb55c49cdcd11e4e7135e0e7e79259c35492a3df4766
+PKG_VERSION:=2019.4
+PKG_RELEASE:=0
+PKG_HASH:=b5525b396595004654335ac1ebf9de1aab90263e66d5bcc43fc8a708b56a18ea
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
diff --git a/alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch b/alfred/patches/0001-alfred-vis-Add-missing-include-for-ifinfomsg.patch
deleted file mode 100644 (file)
index 3a982b8..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Sven Eckelmann <sven@narfation.org>
-Date: Thu, 1 Aug 2019 15:54:32 +0200
-Subject: alfred: vis: Add missing include for ifinfomsg
-
-Fixes: 0fc6e6674428 ("alfred: vis: Retrieve hardif status via generic netlink")
-Signed-off-by: Sven Eckelmann <sven@narfation.org>
-
-Origin: upstream, https://git.open-mesh.org/alfred.git/commit/ce26453bd72829ac9561acd8d3a06a3937341687
-
-diff --git a/vis/vis.c b/vis/vis.c
-index 947456343125458845f26dc38b53f18d6fd42d75..8df3056612d5da3678603a6e6430923c0c86cde0 100644
---- a/vis/vis.c
-+++ b/vis/vis.c
-@@ -10,6 +10,7 @@
- #include <dirent.h>
- #include <errno.h>
- #include <getopt.h>
-+#include <linux/rtnetlink.h>
- #include <net/if.h>
- #include <netinet/in.h>
- #include <signal.h>