batman-adv: upgrade package to latest release 2020.3 602/head
authorSven Eckelmann <sven@narfation.org>
Tue, 25 Aug 2020 18:07:05 +0000 (20:07 +0200)
committerSven Eckelmann <sven@narfation.org>
Tue, 25 Aug 2020 18:09:34 +0000 (20:09 +0200)
* support latest kernels (4.4 - 5.9)
* coding style cleanups and refactoring
* introduce a configurable per interface hop penalty
* bugs squashed:

  - avoid uninitialized chaddr when handling DHCP
  - fix own OGMv2 check in aggregation receive handling
  - fix "NOHZ: local_softirq_pending 08" warnings caused by BLA

Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile
batman-adv/files/lib/netifd/proto/batadv_hardif.sh

index 5813b05853183a17781bec434c09e8744840dc3a..c44324f1ee779ce8640c7cbb94f24a529a3dbb19 100644 (file)
@@ -3,12 +3,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=batman-adv
-PKG_VERSION:=2020.2
+PKG_VERSION:=2020.3
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.open-mesh.org/batman/releases/batman-adv-$(PKG_VERSION)
-PKG_HASH:=a73f5ce72c6efa9dd7bd7cc8daa667d0982e12e40811c978bb652607bb5666a3
+PKG_HASH:=65516dca919ea5be58d141c78bd1f0a94a02a784c5c85fb4e8f27f4226803f73
 PKG_EXTMOD_SUBDIRS:=net/batman-adv
 
 PKG_MAINTAINER:=Simon Wunderlich <sw@simonwunderlich.de>
index 6eb597ff610683ce4d478e83d4515fe518228329..b2f87dd6c24eb67e68da1dc66270d9aa67af8140 100755 (executable)
@@ -8,6 +8,7 @@
 
 proto_batadv_hardif_init_config() {
        proto_config_add_int 'elp_interval'
+       proto_config_add_int 'hop_penalty'
        proto_config_add_string "master"
        proto_config_add_string 'throughput_override'
 }
@@ -17,10 +18,12 @@ proto_batadv_hardif_setup() {
        local iface="$2"
 
        local elp_interval
+       local hop_penalty
        local master
        local throughput_override
 
        json_get_vars elp_interval
+       json_get_vars hop_penalty
        json_get_vars master
        json_get_vars throughput_override
 
@@ -29,6 +32,7 @@ proto_batadv_hardif_setup() {
        batctl meshif "$master" interface -M add "$iface"
 
        [ -n "$elp_interval" ] && batctl hardif "$iface" elp_interval "$elp_interval"
+       [ -n "$hop_penalty" ] && batctl hardif "$iface" hop_penalty "$hop_penalty"
        [ -n "$throughput_override" ] && batctl hardif "$iface" throughput_override "$throughput_override"
 
        proto_init_update "$iface" 1