naywatch: warn user
authorNick Hainke <vincent@systemli.org>
Mon, 15 Nov 2021 18:22:56 +0000 (19:22 +0100)
committerNick Hainke <vincent@systemli.org>
Mon, 15 Nov 2021 18:37:03 +0000 (19:37 +0100)
Naywatch in combination with the watchdog can be tricky and dangerous
when doing a sysupgrade. Add a warning to always stop naywatch first and
check if procd took control over the watchdog again.

Also change use_watchdog to '0'.

Signed-off-by: Nick Hainke <vincent@systemli.org>
naywatch/Makefile
naywatch/files/naywatch.config

index 288f16281711b5ae90f8a989b341ed2ff3a68236..f79890f0190cb3426488ac9705b69b6affd0f969 100644 (file)
@@ -23,7 +23,12 @@ define Package/naywatch
 endef
 
 define Package/naywatch/description
-Reboots or triggers watchdog if no link local neighbor is available.
+Reboots or triggers watchdog if no link-local neighbor is available.
+
+Important:
+Be careful when you do a sysupgrade. Stop naywatch first, and make
+sure procd took control again of the watchdog.
+You can do this using 'ubus call system watchdog'.  Status should be "running".
 endef
 
 define Package/naywatch/conffiles
index 27147a6075b8ef93e12c853d99c7c52deb9c5988..b25e1f209a358228c01817334f70e95c0843b0e2 100644 (file)
@@ -1,7 +1,7 @@
 config naywatch general
     option check_interval   '50'
     option watchdog_timeout '60'
-    option use_watchdog     '1'
+    option use_watchdog     '0'
     option save_logs        '1'
     list interface          'lan'
     list interface          'wan'