batman-adv: Don't try to set unconfigured ap_isolation for vlan 478/head
authorSven Eckelmann <sven@narfation.org>
Sun, 16 Jun 2019 07:27:08 +0000 (09:27 +0200)
committerSven Eckelmann <sven@narfation.org>
Sun, 16 Jun 2019 07:29:42 +0000 (09:29 +0200)
The ap_isolation setting only supports boolean values. So setting an empty
string as ap_isolation is not supported by batctl.

Fixes: f5205d7d2434 ("batman-adv: upgrade package to latest release 2014.2.0")
Signed-off-by: Sven Eckelmann <sven@narfation.org>
batman-adv/Makefile
batman-adv/files/lib/netifd/proto/batadv_vlan.sh

index 84f22748c1ea4fb49c894af535e2d347323398cb..b84475a43ad7b149dbbceee575649f1b74a549f0 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2019.2
 PKG_NAME:=batman-adv
 
 PKG_VERSION:=2019.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_HASH:=70c3f6a6cf88d2b25681a76768a52ed92d9fe992ba8e358368b6a8088757adc8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_HASH:=70c3f6a6cf88d2b25681a76768a52ed92d9fe992ba8e358368b6a8088757adc8
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
index d6d00ad488cb4cec47d370559b3585c5f513ff80..b4835f6d703c97da34f95caf94bfef9ea0ff9963 100755 (executable)
@@ -5,7 +5,7 @@
 init_proto "$@"
 
 proto_batadv_vlan_init_config() {
 init_proto "$@"
 
 proto_batadv_vlan_init_config() {
-       proto_config_add_string "ap_isolation"
+       proto_config_add_boolean 'ap_isolation:bool'
 }
 
 proto_batadv_vlan_setup() {
 }
 
 proto_batadv_vlan_setup() {
@@ -17,7 +17,7 @@ proto_batadv_vlan_setup() {
 
        json_get_vars ap_isolation
 
 
        json_get_vars ap_isolation
 
-       batctl -m "$iface" ap_isolation "$ap_isolation"
+       [ -n "$ap_isolation" ] && batctl -m "$iface" ap_isolation "$ap_isolation"
        proto_init_update "$iface" 1
        proto_send_update "$config"
 }
        proto_init_update "$iface" 1
        proto_send_update "$config"
 }