nodogsplash: add missing config options 411/head
authorRob White <rob@blue-wave.net>
Sat, 15 Sep 2018 09:02:54 +0000 (10:02 +0100)
committerRob White <rob@blue-wave.net>
Sat, 15 Sep 2018 09:02:54 +0000 (10:02 +0100)
sessiontimeout (minutes) until client is forced out
checkinterval (seconds) interval at which nodogsplash checks client timeout status

Add real world useful values to timeout options.

Signed-off-by: Rob White rob@blue-wave.net
nodogsplash/Makefile
nodogsplash/files/etc/config/nodogsplash
nodogsplash/files/etc/init.d/nodogsplash

index 786891b3467e2516afbde9f74106fa800e353f18..e9060c442d1f9ec9ea6f52eca95a29ff7ee83fa6 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=nodogsplash
 PKG_FIXUP:=autoreconf
 PKG_VERSION:=3.2.0
-PKG_RELEASE:=0
+PKG_RELEASE:=1
 
 PKG_SOURCE_URL:=https://codeload.github.com/nodogsplash/nodogsplash/tar.gz/v$(PKG_VERSION)?
 PKG_SOURCE:=nodogsplash-$(PKG_VERSION).tar.gz
index b7bd13c651040a603387402ea3eb6ade34b13481..714d9bfecf715b8d62e006498089411a32dcb1ac 100644 (file)
@@ -27,8 +27,13 @@ config nodogsplash
   #option debuglevel '7'
 
   # Client timeouts in minutes
-  option preauthidletimeout '10'
+  option preauthidletimeout '30'
   option authidletimeout '120'
+  # Session Timeout is the interval after which clients are forced out (a value of 0 means never)
+  option sessiontimeout '1200'
+
+  # The interval in seconds at which nodogsplash checks client timeout status
+  option checkinterval '600'
 
   # Enable BinAuth Support.
   # If set, a program is called with several parameters on authentication (request) and deauthentication.
index d9f4633c59594525500ad44bf6f1e1c29daf5f9d..3c3335c06d98c4fe03aee8d610ddbeb1adfb1239 100755 (executable)
@@ -139,9 +139,10 @@ generate_uci_config() {
   for option in binauth fasport fasremoteip faspath fas_secure_enabled \
     daemon debuglevel maxclients gatewayname gatewayinterface gatewayiprange \
     gatewayaddress gatewayport webroot splashpage statuspage imagesdir pagesdir \
-    redirecturl preauthidletimeout authidletimeout checkinterval setmss mssvalue \
-    trafficcontrol downloadlimit uploadlimit downloadimq uploadimq syslogfacility \
-    ndsctlsocket fw_mark_authenticated fw_mark_blocked fw_mark_trusted
+    redirecturl sessiontimeout preauthidletimeout authidletimeout checkinterval \
+    setmss mssvalue trafficcontrol downloadlimit uploadlimit \
+    syslogfacility ndsctlsocket fw_mark_authenticated \
+    fw_mark_blocked fw_mark_trusted
   do
     config_get val "$cfg" "$option"