Merge pull request #145 from ecsv/alfred_2016.0
authorSimon Wunderlich <sw@simonwunderlich.de>
Fri, 25 Mar 2016 19:32:24 +0000 (20:32 +0100)
committerSimon Wunderlich <sw@simonwunderlich.de>
Fri, 25 Mar 2016 19:32:24 +0000 (20:32 +0100)
Alfred 2016.0

16 files changed:
alfred/files/alfred.init
babeld/Makefile
bmx7/Makefile
bmx7/files/etc/config/bmx6 [deleted file]
bmx7/files/etc/config/bmx7 [new file with mode: 0644]
bmx7/files/etc/init.d/bmx6 [deleted file]
bmx7/files/etc/init.d/bmx7 [new file with mode: 0755]
bmx7/patches/001-json-c.patch
cjdns/Makefile
luci-app-bmx6/files/usr/lib/lua/luci/model/bmx6json.lua
luci-app-bmx6/files/usr/lib/lua/luci/model/cbi/bmx6/main.lua
olsrd/Makefile
olsrd/files/olsrd.init
oonf-dlep-proxy/Makefile
oonf-dlep-radio/Makefile
oonf-olsrd2/Makefile

index 5ce06c000fc81b6094c1c7f984f29cf32b7e7351..4c9a9e195ada75d8f7b9d42e2b852cc855552bfb 100755 (executable)
@@ -37,6 +37,31 @@ wait_for_dir()
        fi
 }
 
+wait_for_ll_address()
+{
+       local iface="$1"
+       local timeout=30
+
+       echo "${initscript}: waiting $timeout secs for $iface address..."
+       for i in $(seq $timeout); do
+               # We look for
+               # - the link-local address (starts with fe80)
+               # - without tentative flag (bit 0x40 in the flags field; the first char of the flags field begins 38 columns after the fe80 prefix
+               # - on interface $iface
+               if awk '
+                       BEGIN { RET=1 }
+                       /^fe80.{37} [012389ab]/ { if ($6 == "'"$iface"'") RET=0 }
+                       END { exit RET }
+               ' /proc/net/if_inet6; then
+                       return
+               fi
+               sleep 1
+       done
+
+       echo "${initscript}: $iface address not detected, alfred not starting."
+       exit 1
+}
+
 alfred_start()
 {
        local args=""
@@ -62,7 +87,7 @@ alfred_start()
                wait_for_dir "$batmanif" "/sys/class/net/$batmanif/mesh"
        fi
 
-       wait_for_dir "$interface" "/sys/class/net/$interface/"
+       wait_for_ll_address "$interface"
 
        append alfred_args "$args"
        enable=1
index d4b609cde09ae721003db4b38cbef32e245018cd..88a7886cf53629bc041ceead07925f1d16f8fb8b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=babeld
-PKG_VERSION:=1.6.1
+PKG_VERSION:=1.7.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.pps.univ-paris-diderot.fr/~jch/software/files/
-PKG_MD5SUM:=74290f6c3678f314c79bdc0ab99d9f22
+PKG_MD5SUM:=2f71794d4e67f8a5352164ce33611549
 PKG_LICENSE:=MIT
 
 include $(INCLUDE_DIR)/package.mk
index 82006eedd816b4c306009f08d9355795d7baaa16..665956a58c42f00b6bd9ae96c9a37de0c971ad1e 100644 (file)
@@ -32,8 +32,8 @@ PKG_SOURCE_PROTO:=git
 #PKG_SOURCE_URL:=git://bmx6.net/bmx6.git
 PKG_SOURCE_URL:=git://github.com/axn/bmx6.git
 
-PKG_REV:=d0841d4bf42ae406cd5319a857dc294badb1ac8d
-PKG_VERSION:=r2016011801
+PKG_REV:=60143a195478a98e73089566bbfde78cf193ed67
+PKG_VERSION:=r2016021505
 PKG_RELEASE:=4
 PKG_LICENSE:=GPL-2.0
 
@@ -61,7 +61,7 @@ define Package/bmx7/Default
   TITLE:=BMX7 layer 3 routing daemon
   URL:=http://bmx6.net/
   MAINTAINER:=Axel Neumann <neumann@cgws.de>
-  DEPENDS:=+zlib +libpolarssl @!bmx6
+  DEPENDS:=+zlib +libpolarssl
 endef
 
 define Package/bmx7/description
@@ -97,12 +97,6 @@ define Package/bmx7-tun
   TITLE:=ipip-based tunnel plugin (recommended!)
 endef
 
-#define Package/bmx7-quagga
-#  $(call Package/bmx7/Default)
-#  DEPENDS:=bmx7 +bmx7-tun +qmp-quagga @BROKEN
-#  TITLE:=bmx7 quagga plugin to redistribute/export routes (needs manet/bmx patched quagga 0.99.21)
-#endef
-
 define Package/bmx7-table
   $(call Package/bmx7/Default)
   DEPENDS:=bmx7 +bmx7-tun
@@ -119,60 +113,55 @@ endef
 
 define Package/bmx7/install
        $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/config $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bmx6 $(1)/usr/sbin/bmx6
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/bmx7 $(1)/usr/sbin/bmx7
 endef
 
 define Package/bmx7/postinst
 #!/bin/sh
 # # check if we are on real system
 if [ -z "$${IPKG_INSTROOT}" ]; then
-       if [ -f /etc/sysupgrade.conf ] && ! grep bmx6 /etc/sysupgrade.conf; then
-               echo /etc/bmx6 >> /etc/sysupgrade.conf
+       if [ -f /etc/sysupgrade.conf ] && ! grep bmx7 /etc/sysupgrade.conf; then
+               echo /etc/bmx7 >> /etc/sysupgrade.conf
         fi
 fi
 endef
 
 
 define Package/bmx7-uci-config/conffiles
-/etc/config/bmx6
+/etc/config/bmx7
 endef
 
 define Package/bmx7-uci-config/install
        $(INSTALL_DIR) $(1)/usr/lib $(1)/etc/config $(1)/etc/init.d
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_uci_config/bmx6_config.so $(1)/usr/lib/bmx6_config.so
-       $(INSTALL_BIN) ./files/etc/init.d/bmx6 $(1)/etc/init.d/bmx6
-       $(INSTALL_DATA) ./files/etc/config/bmx6 $(1)/etc/config/bmx6
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_uci_config/bmx7_config.so $(1)/usr/lib/bmx7_config.so
+       $(INSTALL_BIN) ./files/etc/init.d/bmx7 $(1)/etc/init.d/bmx7
+       $(INSTALL_DATA) ./files/etc/config/bmx7 $(1)/etc/config/bmx7
 endef
 
 define Package/bmx7-json/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_json/bmx6_json.so $(1)/usr/lib/bmx6_json.so
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_json/bmx7_json.so $(1)/usr/lib/bmx7_json.so
 endef
 
 define Package/bmx7-sms/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_sms/bmx6_sms.so $(1)/usr/lib/bmx6_sms.so
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_sms/bmx7_sms.so $(1)/usr/lib/bmx7_sms.so
 endef
 
 define Package/bmx7-tun/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_tun/bmx6_tun.so $(1)/usr/lib/bmx6_tun.so
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_tun/bmx7_tun.so $(1)/usr/lib/bmx7_tun.so
 endef
 
 define Package/bmx7-table/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_table/bmx6_table.so $(1)/usr/lib/bmx6_table.so
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx7_table/bmx7_table.so $(1)/usr/lib/bmx7_table.so
 endef
 
-#define Package/bmx7-quagga/install
-#      $(INSTALL_DIR) $(1)/usr/lib
-#      $(INSTALL_BIN) $(PKG_BUILD_DIR)/lib/bmx6_quagga/bmx6_quagga.so $(1)/usr/lib/bmx6_quagga.so
-#endef
 
 $(eval $(call BuildPackage,bmx7))
 $(eval $(call BuildPackage,bmx7-uci-config))
 $(eval $(call BuildPackage,bmx7-json))
 $(eval $(call BuildPackage,bmx7-sms))
-#$(eval $(call BuildPackage,bmx7-quagga))
 $(eval $(call BuildPackage,bmx7-table))
 $(eval $(call BuildPackage,bmx7-tun))
diff --git a/bmx7/files/etc/config/bmx6 b/bmx7/files/etc/config/bmx6
deleted file mode 100644 (file)
index 26d691c..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-
-# for more information:
-# http://bmx6.net/projects/bmx6/wiki
-# options execute: bmx6 --help
-
-config 'bmx6' 'general'
-#       option 'runtimeDir' '/var/run/bmx6'
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_config.so'
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_json.so'
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_sms.so'
-
-
-config 'dev' 'mesh_1'
-        option 'dev' 'br-lan'
-
-config 'dev' 'mesh_2'
-        option 'dev' 'wlan0'
-
-
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_tun.so'
-
-#config 'plugin'
-#        option 'plugin' 'bmx6_table.so'
-
-
-#config 'tunDev' default
-#        option 'tunDev' 'default'
-#        option 'tun6Address' '2012:0:0:6666::1/64'
-#        option 'tun4Address' '10.66.66.1/24'
-
-
-#config 'tunOut'
-#        option 'tunOut' 'ip6'
-#        option 'network' '2012::/16'
-#        option 'exportDistance' '0'
-
-#config 'tunOut'
-#        option 'tunOut' 'ip4'
-#        option 'network' '10.0.0.0/9'
-#        option 'minPrefixLen' '27'
-
-
-
-
-
diff --git a/bmx7/files/etc/config/bmx7 b/bmx7/files/etc/config/bmx7
new file mode 100644 (file)
index 0000000..7593ede
--- /dev/null
@@ -0,0 +1,54 @@
+
+# for more information:
+# http://bmx6.net/projects/bmx6/wiki
+# options execute: bmx7 --help
+
+config 'bmx7' 'general'
+#       option 'runtimeDir' '/var/run/bmx7'
+#      option 'trustedNodesDir' '/etc/bmx7/trustedNodes'
+
+#config 'plugin'
+#        option 'plugin' 'bmx7_config.so'
+
+#config 'plugin'
+#        option 'plugin' 'bmx7_json.so'
+
+#config 'plugin'
+#        option 'plugin' 'bmx7_sms.so'
+
+
+config 'dev' 'mesh_1'
+        option 'dev' 'br-lan'
+
+config 'dev' 'mesh_2'
+        option 'dev' 'wlan0'
+
+
+
+#config 'plugin'
+#        option 'plugin' 'bmx7_tun.so'
+
+#config 'plugin'
+#        option 'plugin' 'bmx7_table.so'
+
+
+#config 'tunDev' default
+#        option 'tunDev' 'default'
+#        option 'tun6Address' '2012:0:0:6666::1/64'
+#        option 'tun4Address' '10.66.66.1/24'
+
+
+#config 'tunOut'
+#        option 'tunOut' 'ip6'
+#        option 'network' '2012::/16'
+#        option 'exportDistance' '0'
+
+#config 'tunOut'
+#        option 'tunOut' 'ip4'
+#        option 'network' '10.0.0.0/9'
+#        option 'minPrefixLen' '27'
+
+
+
+
+
diff --git a/bmx7/files/etc/init.d/bmx6 b/bmx7/files/etc/init.d/bmx6
deleted file mode 100755 (executable)
index cb2d5b3..0000000
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh /etc/rc.common
-#    Copyright (C) 2011 Fundacio Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net
-#
-#    This program is free software; you can redistribute it and/or modify
-#    it under the terms of the GNU General Public License as published by
-#    the Free Software Foundation; either version 2 of the License, or
-#    (at your option) any later version.
-#
-#    This program is distributed in the hope that it will be useful,
-#    but WITHOUT ANY WARRANTY; without even the implied warranty of
-#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-#    GNU General Public License for more details.
-#
-#    You should have received a copy of the GNU General Public License along
-#    with this program; if not, write to the Free Software Foundation, Inc.,
-#    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
-#
-#    The full GNU General Public License is included in this distribution in
-#    the file called "COPYING".
-
-START=91
-
-BIN=/usr/sbin/bmx6
-CONF=/etc/config/bmx6
-PID=/var/run/bmx6/pid
-
-
-start() {
-       cd /root/
-       while pgrep -f mac80211.sh ; do sleep 1; done
-       ulimit -c 20000
-       $BIN -f $CONF -d0 > /dev/null &
-}
-
-stop() {
-       start-stop-daemon -p $PID -K
-}
-
-restart() {
-       stop; sleep 3; start
-}
diff --git a/bmx7/files/etc/init.d/bmx7 b/bmx7/files/etc/init.d/bmx7
new file mode 100755 (executable)
index 0000000..6886739
--- /dev/null
@@ -0,0 +1,41 @@
+#!/bin/sh /etc/rc.common
+#    Copyright (C) 2011 Fundacio Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net
+#
+#    This program is free software; you can redistribute it and/or modify
+#    it under the terms of the GNU General Public License as published by
+#    the Free Software Foundation; either version 2 of the License, or
+#    (at your option) any later version.
+#
+#    This program is distributed in the hope that it will be useful,
+#    but WITHOUT ANY WARRANTY; without even the implied warranty of
+#    MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+#    GNU General Public License for more details.
+#
+#    You should have received a copy of the GNU General Public License along
+#    with this program; if not, write to the Free Software Foundation, Inc.,
+#    51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
+#
+#    The full GNU General Public License is included in this distribution in
+#    the file called "COPYING".
+
+START=91
+
+BIN=/usr/sbin/bmx7
+CONF=/etc/config/bmx7
+PID=/var/run/bmx7/pid
+
+
+start() {
+       cd /root/
+       while pgrep -f mac80211.sh ; do sleep 1; done
+       ulimit -c 20000
+       $BIN -f $CONF -d0 > /dev/null &
+}
+
+stop() {
+       start-stop-daemon -p $PID -K
+}
+
+restart() {
+       stop; sleep 3; start
+}
index 5d29dae43cc624e4cccf00bf4941bd47890fd4ff..794bd9e87fac73ea47f1863bc5fac75e43b9c37a 100644 (file)
@@ -1,7 +1,7 @@
-Index: bmx6-r2014112401/lib/bmx6_json/json.c
+Index: bmx7-r2014112401/lib/bmx7_json/json.c
 ===================================================================
---- bmx6-r2014112401.orig/lib/bmx6_json/json.c
-+++ bmx6-r2014112401/lib/bmx6_json/json.c
+--- bmx7-r2014112401.orig/lib/bmx7_json/json.c
++++ bmx7-r2014112401/lib/bmx7_json/json.c
 @@ -27,7 +27,7 @@
  #include <unistd.h>
  #include <fcntl.h>
index 6f7a6af1562130b58d64577fe5c59dab4a62f04f..a81b49144cfe66598ccbddcd68088c09ffa49edf 100644 (file)
@@ -18,11 +18,11 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cjdns
 PKG_VERSION:=0.17
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=https://github.com/hyperboria/cjdns.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=1cf53a812a9b19e5ce883c16d40ac183f61d43f6
+PKG_SOURCE_VERSION:=40e87d9419c19063e772e39c7c59a8a8771c5ee8
 PKG_LICENSE:=GPL-3.0
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
@@ -66,7 +66,7 @@ endef
 define Build/Configure
 endef
 
-PKG_DO_VARS:=
+PKG_DO_VARS:=CJDNS_RELEASE_VERSION=$(PKG_SOURCE_VERSION)
 
 ifneq ($(CONFIG_KERNEL_SECCOMP_FILTER),y)
 PKG_DO_VARS+= Seccomp_NO=1
index dfe9ab1f393453fee018bd88f044bbe1719ee946..a4a8e438ef5d63acafb2458f18ffc1afbdee8f8e 100644 (file)
@@ -112,12 +112,16 @@ function wget(url, timeout)
        if pid == 0 then
                rfd:close()
                nixio.dup(wfd, nixio.stdout)
-
-               local candidates = { "/usr/bin/wget", "/bin/wget" }
+               -- candidates for wget, try first ones with SSL support
+               local candidates = {{"/usr/bin/wget-ssl",1},{"/usr/bin/wget",0},{"/bin/wget",0}}
                local _, bin
                for _, bin in ipairs(candidates) do
-                       if nixiofs.access(bin, "x") then
-                               nixio.exec(bin, "-q", "-O", "-", url)
+                       if nixiofs.access(bin[1], "x") then
+                               if bin[2] == 0 then
+                                       nixio.exec(bin[1], "-q", "-O", "-", url)
+                               else
+                                       nixio.exec(bin[1], "--no-check-certificate", "-q", "-O", "-", url)
+                               end
                        end
                end
                return
index d4e0745aa668058e2976ac669e132455eb5ebe6a..8ff35202f5f9536f0f28b42226f82b312f6cc182 100644 (file)
@@ -27,7 +27,8 @@ m = Map("bmx6", "bmx6")
 -- Getting json and Checking if bmx6-json is avaiable
 local options = bmx6json.get("options")
 if options == nil or options.OPTIONS == nil then
-        m.message = "bmx6-json plugin is not running or some mistake in luci-bmx6 configuration, check /etc/config/luci-bmx6"
+       m.message = "bmx6-json plugin is not running or some mistake in luci-bmx6 configuration, check /etc/config/luci-bmx6"
+       return m
 else
        options = options.OPTIONS
 end
index 16cf47446c58f86158dd7a6de4f9cdb4a7b59653..e6f85f7638800af1335ad64b0f59223e88910137 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2009-2012 OpenWrt.org
+# Copyright (C) 2009-2016 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -12,7 +12,7 @@ PKG_VERSION:=0.9.0.3
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=http://olsr.org/git/olsrd.git
+PKG_SOURCE_URL:=https://github.com/OLSR/olsrd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=v0.9.0.3
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
index 3ced9118197176adfb50ab7f855dcff9dd29c191..43c7e67311cd488a3edd965bf9a6a159d2030a28 100644 (file)
@@ -397,7 +397,7 @@ olsrd_write_olsrd() {
        [ "$OLSRD_COUNT" -gt 0 ] && return 0
 
        config_get ipversion "$cfg" IpVersion
-       if [ "$UCI_CONF_NAME" == "olsrd6" ]; then
+       if [ "$UCI_CONF_NAME" = "olsrd6" ]; then
                OLSRD_OLSRD_SCHEMA="$OLSRD_OLSRD_SCHEMA IpVersion=6"
                if [ "$ipversion" = "6and4" ]; then
                        error "IpVersion 6and4 not supported in olsrd6"
@@ -703,21 +703,29 @@ olsrd_setup_smartgw_rules() {
        IP6T=$(which ip6tables)
 
        # Delete smartgw firewall rules first
-       for IPT in $IP4T $IP6T; do
-               while $IPT -D forwarding_rule -o tnl_+ -j ACCEPT 2> /dev/null; do :;done
+       if [ "$UCI_CONF_NAME" = "olsrd6" ]; then
+               while $IP6T -D forwarding_rule -o tnl_+ -j ACCEPT 2> /dev/null; do :;done
                for IFACE in $wanifnames; do
-                       while $IPT -D forwarding_rule -i tunl0 -o $IFACE -j ACCEPT 2> /dev/null; do :; done
+                       while $IP6T -D forwarding_rule -i tunl0 -o $IFACE -j ACCEPT 2> /dev/null; do :; done
                done
                for IFACE in $ifsglobal; do
-                       while $IPT -D input_rule -i $IFACE -p 4 -j ACCEPT 2> /dev/null; do :; done
+                       while $IP6T -D input_rule -i $IFACE -p 4 -j ACCEPT 2> /dev/null; do :; done
                done
-       done
-       while $IP4T -t nat -D postrouting_rule -o tnl_+ -j MASQUERADE 2> /dev/null; do :;done
+       else
+               while $IP4T -D forwarding_rule -o tnl_+ -j ACCEPT 2> /dev/null; do :;done
+               for IFACE in $wanifnames; do
+                       while $IP4T -D forwarding_rule -i tunl0 -o $IFACE -j ACCEPT 2> /dev/null; do :; done
+               done
+               for IFACE in $ifsglobal; do
+                       while $IP4T -D input_rule -i $IFACE -p 4 -j ACCEPT 2> /dev/null; do :; done
+               done
+               while $IP4T -t nat -D postrouting_rule -o tnl_+ -j MASQUERADE 2> /dev/null; do :;done
+       fi
 
-       if [ "$smartgateway" == "yes" ]; then
+       if [ "$smartgateway" = "yes" ]; then
                log "$funcname() Notice: Inserting firewall rules for SmartGateway"
-               if [ ! "$smartgatewayuplink" == "none" ]; then
-                       if [ "$smartgatewayuplink" == "ipv4" ]; then
+               if [ ! "$smartgatewayuplink" = "none" ]; then
+                       if [ "$smartgatewayuplink" = "ipv4" ]; then
                                # Allow everything to be forwarded to tnl_+ and use NAT for it
                                $IP4T -I forwarding_rule -o tnl_+ -j ACCEPT
                                $IP4T -t nat -I postrouting_rule -o tnl_+ -j MASQUERADE
@@ -731,7 +739,7 @@ olsrd_setup_smartgw_rules() {
                                for IFACE in $ifsglobal; do
                                        $IP4T -I input_rule -i $IFACE -p 4 -j ACCEPT
                                done
-                       elif [ "$smartgatewayuplink" == "ipv6" ]; then
+                       elif [ "$smartgatewayuplink" = "ipv6" ]; then
                                $IP6T -I forwarding_rule -o tnl_+ -j ACCEPT
                                if [ "$nowan"="0" ]; then
                                        for IFACE in $wanifnames; do
index ed9a52f053d0a167e81354f6255228d5a47144e3..9a0d79b936697c2784042f7094811aa78a7b0e03 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-proxy
-PKG_VERSION:=0.9.2
-PKG_REV:=d1780791bd449f578a37a2b3103682169d9a01a9
+PKG_VERSION:=0.11.2
+PKG_REV:=a9a789405a6e5ef321a801f5a96c0440f20c16ae
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://olsr.org/git/oonf.git
+PKG_SOURCE_URL:=https://github.com/OLSR/OONF.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -21,7 +21,7 @@ CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \
               -D OONF_APP_DEFAULT_CFG_HANDLER:String=uci \
-              -D OONF_STATIC_PLUGINS:String="class;clock;interface;layer2;packet_socket;socket;stream_socket;telnet;timer;viewer;os_clock;os_socket;os_interface;os_system;nl80211_listener;layer2info;systeminfo;cfg_uciloader;cfg_compact;dlep_proxy" \
+              -D OONF_STATIC_PLUGINS:String="class;clock;interface;layer2;packet_socket;socket;stream_socket;telnet;timer;viewer;os_clock;os_fd;os_interface;os_system;nl80211_listener;layer2info;systeminfo;cfg_uciloader;cfg_compact;dlep_proxy" \
               -D OONF_LIB_GIT:String=v$(PKG_VERSION)-archive \
               -D OONF_VERSION:String=$(PKG_VERSION) \
               -D INSTALL_LIB_DIR:Path=lib/oonf \
index aedf2da31625b564c3209b723b8d8f4e39925c15..6d99fb9f030fde8e7076a81593336bf6cd37fcd8 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-dlep-radio
-PKG_VERSION:=0.9.2
-PKG_REV:=d1780791bd449f578a37a2b3103682169d9a01a9
+PKG_VERSION:=0.11.2
+PKG_REV:=a9a789405a6e5ef321a801f5a96c0440f20c16ae
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://olsr.org/git/oonf.git
+PKG_SOURCE_URL:=https://github.com/OLSR/OONF.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -21,7 +21,7 @@ CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \
               -D OONF_APP_DEFAULT_CFG_HANDLER:String=uci \
-              -D OONF_STATIC_PLUGINS:String="class;clock;interface;layer2;packet_socket;socket;stream_socket;telnet;timer;viewer;os_clock;os_socket;os_interface;os_system;nl80211_listener;layer2info;systeminfo;cfg_uciloader;cfg_compact;dlep_radio" \
+              -D OONF_STATIC_PLUGINS:String="class;clock;interface;layer2;packet_socket;socket;stream_socket;telnet;timer;viewer;os_clock;os_fd;os_interface;os_system;nl80211_listener;layer2info;systeminfo;cfg_uciloader;cfg_compact;dlep_radio" \
               -D OONF_LIB_GIT:String=v$(PKG_VERSION)-archive \
               -D OONF_VERSION:String=$(PKG_VERSION) \
               -D INSTALL_LIB_DIR:Path=lib/oonf \
index 3cfd32157263a222ad7154e326a29ff182420f4a..118f0a266116fd57de47db1b0b7fc3a443225e01 100644 (file)
@@ -1,12 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=oonf-olsrd2
-PKG_VERSION:=0.9.2
-PKG_REV:=d1780791bd449f578a37a2b3103682169d9a01a9
+PKG_VERSION:=0.11.2
+PKG_REV:=a9a789405a6e5ef321a801f5a96c0440f20c16ae
 PKG_RELEASE:=$(PKG_REV)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://olsr.org/git/oonf.git
+PKG_SOURCE_URL:=https://github.com/OLSR/OONF.git
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_VERSION:=$(PKG_REV)
@@ -21,7 +21,7 @@ CMAKE_OPTIONS=-D OONF_NO_WERROR:Bool=true \
               -D OONF_NO_TESTING:Bool=true \
               -D UCI:Bool=true \
               -D OONF_APP_DEFAULT_CFG_HANDLER:String=uci \
-              -D OONF_STATIC_PLUGINS:String="class;clock;duplicate_set;interface;layer2;packet_socket;rfc5444;socket;stream_socket;telnet;timer;viewer;os_clock;os_socket;os_interface;os_routing;os_system;nhdp;olsrv2;ff_dat_metric;neighbor_probing;nl80211_listener;link_config;layer2info;systeminfo;cfg_uciloader;cfg_compact;nhdpinfo;olsrv2info;netjsoninfo" \
+              -D OONF_STATIC_PLUGINS:String="class;clock;duplicate_set;interface;layer2;packet_socket;rfc5444;socket;stream_socket;telnet;timer;viewer;os_clock;os_fd;os_interface;os_routing;os_system;nhdp;olsrv2;ff_dat_metric;neighbor_probing;nl80211_listener;link_config;layer2info;systeminfo;cfg_uciloader;cfg_compact;nhdpinfo;olsrv2info;netjsoninfo" \
               -D OONF_LIB_GIT:String=v$(PKG_VERSION)-archive \
               -D OONF_VERSION:String=$(PKG_VERSION) \
               -D INSTALL_LIB_DIR:Path=lib/oonf \