bird1: fix compilation with GCC 10 592/head
authorRosen Penev <rosenp@gmail.com>
Tue, 11 Aug 2020 19:25:58 +0000 (12:25 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 11 Aug 2020 19:36:05 +0000 (12:36 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
bird1/Makefile
bird1/patches/010-gcc10.patch [new file with mode: 0644]

index 4e7542e07d748138f7747d44c0f26430578ae522..33df35f635116d50d0b708c18ea978105bc23cfd 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird1
 PKG_VERSION:=1.6.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
diff --git a/bird1/patches/010-gcc10.patch b/bird1/patches/010-gcc10.patch
new file mode 100644 (file)
index 0000000..beb4e03
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/sysdep/unix/krt.h
++++ b/sysdep/unix/krt.h
+@@ -112,7 +112,7 @@ struct kif_proto {
+   struct kif_state sys;               /* Sysdep state */
+ };
+-struct kif_proto *kif_proto;
++extern struct kif_proto *kif_proto;
+ #define KIF_CF ((struct kif_config *)p->p.cf)